Welcome to TP-LINK Tech Support Forum
+ Reply to Thread
Page 2 of 2 FirstFirst 1 2
Results 16 to 26 of 26
  1. #16
    Contact tplink for a beta firmware. Mine WA850RE works fine after the update.

  2. #17
    Quote Originally Posted by uutommi View Post
    Contact tplink for a beta firmware. Mine WA850RE works fine after the update.
    Thanks, I sent a support request to TP-Link, waiting for their reply now.

  3. #18
    AL D
    Guest
    Quote Originally Posted by AL D View Post
    I have the same problem. I went through the setup process multiple times with the same result. The unit does not get an ip addressed assigned I believe due to the fact that the password isn't recognized for it asks for the correct password to be provided although the correct password was given initially. ???
    My original post addressed the fact that I could not connect with the RE-305(us) with my Macbook Air. The problem was rectified by taking under advisement "PerfectingLife" suggestion to install the upgrades available for the unit. Visiting the download site, I seen 3 upgrades listed for the unit and decided to downgrade the oldest one first with the intent of working my way through the remaining two afterwards. Well, I'm happy to say that the 1st download solved the problem. Since almost a year has past since I had the problem and having it rectified by the 1st upgrade, I am not going to attempt to download the remaining two. I guess you could say that I'm - gun shy! lol... It's working leave it alone I say.

    One detail that I forgot to mention in my original post was the fact that I was able to connect via 2.4 Ghz band but not the 5 Ghz band. This upgrade fixed that.

  4. #19
    what is the hardware version and firmware version of your range extenders? any it is EU or US versions?

  5. #20
    Quote Originally Posted by uutommi View Post
    what is the hardware version and firmware version of your range extenders? any it is EU or US versions?
    I have a RE500 v1 (EU), firmware version 1.0.3 20171219 release 72740 (6985)

  6. #21
    like

  7. #22
    I tried downgrading to 1.0.1 Build 20170420 Rel. 33429, still can't connect to my RE500 Wifi Access Point with my Macbook Pro

  8. #23
    i contact tp-link and they gave me this beta link. you can have a try.
    http://static.tp-link.com/RE500_V1_170928_beta.zip
    Quote Originally Posted by adamska View Post
    I tried downgrading to 1.0.1 Build 20170420 Rel. 33429, still can't connect to my RE500 Wifi Access Point with my Macbook Pro

  9. #24
    Quote Originally Posted by Enson Loo View Post
    i contact tp-link and they gave me this beta link. you can have a try.
    http://static.tp-link.com/RE500_V1_170928_beta.zip
    Wow, installed this beta version and guess what, all my computers and mobile devices can now connect to the AP ! Thank you !

    I am not sure this version includes KRACK vulnerability patches (as it seems to be dated 17/09/28), but I am very happy my Macbook can now connect flawlessly to my RE500.

    Looking forward to a new update that solves all these issues while including all recent security updates and NTP bug fix.

  10. #25
    Junior Member millihertz is on a distinguished road
    Join Date
    May 2018
    Posts
    1

    Same issue on RE200

    Hello,
    I'm facing the same problem using RE200: my iPhone connects to the extended WiFi ok. But my 2010 MacBook Pro (Sierra) gives me an invalid password error when I try to connect. (It connects to the main router WiFi ok).

    I have tried different security options on the admin/control panel page of RE200 (WPA, WPA2, etc.) and none seem to change/fix it.

    There's clearly something going on with TP Link products that's causing all these problems for Mac users...

  11. #26
    Looking for the same solution.


 

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts

Copyright 1996-2018 TP-LINK Technologies Co., Ltd. All rights reserved.