Welcome to TP-LINK Tech Support Forum
+ Reply to Thread
Page 2 of 3 FirstFirst 1 2 3 LastLast
Results 16 to 30 of 31
  1. #16
    Quote Originally Posted by bdhamm View Post
    this worked for me also.. I agree it is a BAD solution as my wireless signal sucks where my xbox one is in the house and i cannot move the modem closer... they need to fix this problem SOON.
    As far as I can tell, they haven't even acknowledged the problem yet.

  2. #17
    Thank you very much for your email requesting information about our product and sorry for any inconvenience caused.
    Last edited by kaufen; 01-26-2018 at 14:45.

  3. #18

    got a reply, but it doesn't help at all.......

    Dear Brian,
    Thank you very much for your email requesting information about our product.

    We have already released an official firmware for this issue.
    However , the cable modem is a little special. We need to send this firmware to the internet service provides at first. After they test it and make sure that is working fine with their server. They will update it for you on their side.

    We are not sure the exact time when they will finish the test and update it for you.
    You can also try to contact your internet service provider for detailed information.

    Sorry for the inconvenience caused, and have a nice day.

  4. #19
    Junior Member Arturo is on a distinguished road
    Join Date
    Apr 2017

    Exclamation Same

    It's been 4 months since this problem started, how long does it take for an ISP to clear the firmware?

  5. #20
    Sssoooo... no way of knowing when my ISP does push the update beyond me periodically checking ???

  6. #21
    I have to push on this issue also. It is becoming ridiculous. TWC is not cooperating. They will not tell me what the latest approved firmware version is so that I may compare it against what I currently have. They will not acknowledge whether or not they are even testing a firmware update. I am getting zero support on the ISP side.

    Also, can someone at TP-Link please confirm if a firmware fix has also been issued for the TC-W7960? So far I only see discussion of the AC1750.

  7. #22
    I have the same problem, XBOX One S won't connect to Netflix. Plus another problem: I can't access Dish Anywhere remotely. I talked to Dish Network Support this evening and I was told they were opening a case file on this because there have been other people who own this modem having the same problem. I too tried the "guest network" workaround to no avail, not to mention that this fix would also slow down the entire WIFI network if it did work. It's too late for me to try to return the modem so I am probably going to have to buy another new cable modem. If that's the case I will leave a scathing review on Amazon. Please TP Link, a firmware update should have been issued months ago.

  8. #23
    Junior Member sunandwavs is on a distinguished road
    Join Date
    Apr 2017

    Cool Guest network fixed my issue

    Hi everyone,

    I have a XBOX one. When I switched to a TP-Link Cable Modem TC-W7960, Netflix on X1 stopped working. This was the only streaming service which stopped working. Amazon and Hulu kept on working as did other online games. I reinstalled Netflix, reverted back to factory Xbox settings, rebooted everything 10 times, not to mention called our ISP and had them come out several times. Since this cable modem was rated so highly on Amazon, I did not suspect this router. I finally ran across this thread and enabled the 2.4Ghz guest network. Following these directions: http://www.tp-link.com/us/faq-1154.html

    Bingo bango, Netflix started working on my Xbox one.

    Best of luck to all who search for answers!


  9. #24
    Junior Member jaybollman is on a distinguished road
    Join Date
    May 2017

    I tried talking to netflix, learned some interesting stuff.

    I have been watching this thread for some time, and decided to make an account and pitch in. I am an advanced techie, but do not get your hopes up, I have no answer here. But, I had a chat with Netflix, I was an early adopter of the company, so I have a little sway with my seniority. I know this isn't netflix's fault, but the lady I spoke to had one of her friends from the tech department pitch in, . He, through her, says to call Time Warner/Spectrum and just say you want to talk to a "T2 Tech Support Agent", and they will realize you mean business, and get someone who will help you without having to turn it on and off, and make sure the power cord is connected and such. He says to have the person monitor your DNS on their end, and check for any system hiccups as you try to connect. Suggest to the rep that a friend said to try and match the DNS from the modem to the Xbox. He also stated that if they refuse or say that is not possible, they are full of it, get a supervisor. He says that the issue is typically with the ISP and not the router, or at least the ISP not understanding how the router works. I kind of agree. Next he instructed that if that bares no fruit, to contact Microsoft, and do the same. Microsoft will be more willing but can only help with your Xbox. Also, the lady said it was very handy to have a link to this forum so maybe try giving whatever customer service people you talk too a link, and Netflix is looking into the issue in the morning from their end, but it is very limited as to what could have changed, as the issue did not flare up around any of their updates. In my honest opinion, contacting Netflix will do nothing for us service wise, but now we have some leverage from the top with at least one ticket open. I have not tried any of this yet, but I will tomorrow, and try to get back to you guys.

    What I tried:

    Changing DNS on both ends: nope.

    Hard wire to router: Works.

    Upgraded the Firmware on my own, it just pissed off TWC.

    Downgraded the Firmware two points, also just pissed of TWC.

    I had an old belkin router I used for playing around with, it was like $15 at walmart. I connected that to my Archer, and made a new network on it, confirmed with TWC that I had a separate router (Important to do that for whatever reason). It actually worked for about a day or two, then stopped, and continued to not work after I reset everything and tried it again. While inconvenient, it is a lead. In my opinion, TP must have some kind of patch release affecting the port, and Time Warner has not noticed it is affecting stuff, or vice-versa, either way, I think this one is on Time, not TP, as they are notorious half-assers.

  10. #25

  11. #26
    Junior Member danoise is on a distinguished road
    Join Date
    May 2017
    Also having this issue, just got a new place. Was using the TC 7610 modem last night and it worked fine.But today i upgraded to the tc-w7960 today(obv for wifi capabilities) and now i can't connect at all. Internet works fine , getting same symptoms as the other people here. I didn't think of it being an issue with the modem. Netflix says to call isp (Comcast) and have them reset the signal which i haven't done because i don't believe that's the issue. Other forums with this issue have stated the issue fixes itself but those are a year old answers at least while this thread is much more recent.

  12. #27
    Junior Member danoise is on a distinguished road
    Join Date
    May 2017
    Guest network worked for me, kind of inconvenient. I guess ill try this for a week and if it gets really annoying ill return it.

  13. #28
    We had same problem on my husband's PS4. I ended up changing the hard drive to a 2Tb and reinstalled the app. Works just fine.

  14. #29
    Junior Member KylieSlater266XY is on a distinguished road
    Join Date
    Feb 2018
    before doing such us complex troubleshooting, you may try to do the basic like reboot both devices wifi and the TV ..etc then try to do clear cache .. logout your account then relogin.. if doesnt address your concern on to the basic.. you may try this step by step by following the
    Solution 6. Set domain name system (DNS) to Manual using Smart DNS proxy on this website.
    DNS also provided .

  15. #30

    A quick solution to the Xbox one Netflix isse

    Netflix nw-2-5 error common issue I often faced. After going through some blogs and forum I find more restarting the router solves the issue and if still finding the problem then re-install the app. If you find step by step guide then this blog on Netflix not working on Xbox one has the steps for Xbox one.


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts

Copyright 1996-2018 TP-LINK Technologies Co., Ltd. All rights reserved.