Welcome to TP-LINK Tech Support Forum
+ Reply to Thread
Page 1 of 2 1 2 LastLast
Results 1 to 15 of 21
  1. #1

    Local Wi-fi control only

    Model :

    Hardware Version :

    Firmware Version :

    ISP : [/COLOR]


    I've been using the device for months without any issue, however since shortly the device does not work remotely anymore.
    The settings in the app are good (remote control=on) but if I go back a screen it'll still say Local Wi-Fi control only.

    I've checked and it's not a hidden SSID, I am able to ping the device within my LAN and the app does work when i'm on the same lan.

    But use it mostly to power on remotely so I really need this fixed.

    Resetting the device did not help either


  2. #2

    Local Wi fi control only

    Does any one have all the d-light control firmware. Tried to get it from d-light site, and only has the latest.I think this maybe my problem, because I updated to the latest version could of been a mistake.

  3. #3

    local mode

    bought my mother an amazon echo for her 85th b-day. these smart plugs worked for a week when we set it up. now, local mode only... defeats the purpose. does anybody know what happened?

  4. #4
    I am having the same issue with the app showing "Local Only". Started about a week or so ago.
    I though I would try to turn off remote control and back on to see if that would help. When I try to turn off remote control, after a few seconds I get an error "unbinding failed, error: can not connect to the server"
    I also have this linked to an Amazon Echo and in the Alexa app, it shows the device status as "Offline".

  5. #5

    Question no answer yet

    so, how long does it typically take to resolve an issue on this 'support' forum? mother is not getting any younger and needs to control her lights .

  6. #6
    Ok. So I got an email from support suggesting a factory reset. I performed a factory reset then went back through the setup procedure. I named it the same thing as before and I didn't have to re-link it to the Amazon Echo.

    To reset to factory defaults, press and hold the small button on the top of the plug device (not the one that lights up when the power is on) for around 10 seconds. Then go back through the initial setup procedure.

  7. #7
    @NetworkGuy... sounds like that worked for you. pretty sure I already tried it but I'll give it another shot. thanks.

  8. #8
    @NetworkGay I have had this problem today and after searching in internet I've got your post and it has worked for me too. Tnx.After resetting the Smart Plug I have had to add newly the device, and the Kasa App had the SSID and the password of my net stored, I only have had to go on to the next step until the end.

  9. #9
    Guys, quick question, did you delete the plug from Kasa first or did you just do a factory reset? Seem to be having the same issue apart from that the factory reset hasn't worked......Thanks

  10. #10
    I had a similar problem the first time I set up the smart plugs. I wound up deleting everything from Kasa, hard-resetting all the plugs, re-booting my router, and carefully adding everything back. Since then, I have not had a re-occurrence.

  11. #11
    I was only able to control my device locally and could not even turn on Remote switch; error said not connected to internet. However all my devices were OK on my WiFi, and my Router said I was connected, even listed the correct MAC number. After resets, reboots etc, etc. I finally solved the issue! My Router's Firewall was set to Typical Use, Medium Security. When researching this, I found it was NOT the default setting which was LOW SECURITY level. Medium security prevents P2P connections from passing through, and that's how apparently TP-Link plug communicates over the internet. After changing the setting to LOW, everything suddenly worked. I was able to turn Remote switch to ON and was able to control my device from distant locations from my iPhone. It may not be everyone's issue, but check your Firewalls to see what level they are set for. Either change it or add an exception for TP-Link to get through with P2P.

  12. #12
    Junior Member jessy1 is on a distinguished road
    Join Date
    Oct 2016
    nstall the app. You need to register an account in order to integrate with Alexa or remote control from Internet. It's a typical process the app ask you to connect to the local wifi from the device itself for the setup. The setup process for this device is smooth and fast, in less than 30 second, it just worked.

  13. #13
    I was just about to give up. I saw your post but went to my router and do not know what to change. My Router does not have a security setting of Low & Medium. Do you mean WPA, & WPA2. I gave that a try and will see what happens when I leave the home network

    Thanks for the post.

  14. #14
    To Mpatto: Tocheck the router, go to its IP address in a browser (should give that info on the device or instructions.) Go to SECURITY section and check FIREWALL info. There may be just a separate section for FIREWALL.
    Check the levels available; there is usually a description.

  15. #15

    any luck with this issue ?

    I found the issue. remote controle option is not turned on everything worked fine

    any luck with this issue ? any one able to find the solution.

    I have kasa app. the switch says localonly. tp link switch works fine in kasa. but in alexa it is not working

    Name:  Screenshot_20171225-231857.jpg
Views: 7155
Size:  25.4 KB
    Last edited by krishnagrandhi; 12-26-2017 at 23:34.


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts

Copyright 1996-2018 TP-LINK Technologies Co., Ltd. All rights reserved.