Welcome to TP-LINK Tech Support Forum

Poll: Do you find this article helpful?

Be advised that this is a public poll: other users can see the choice(s) you selected.

Page 1 of 3 1 2 3 LastLast
Results 1 to 15 of 35
  1. #1
    Administrator tplink has disabled reputation
    Join Date
    Mar 2012

    Post How to use firmware recovery function of Pharos CPE

    How to use firmware recovery function of Pharos CPE

    Suitable for
    : Pharos CPE, Pharos BS

    Purpose of this article:
    Firmware upgrade may not be successful sometimes, for instance unpredictable power failure during the process, and thus your Pharos device may fail to reboot. This article will guide you how to re-flash the firmware via TFTP.
    Name:  001.png
Views: 12271
Size:  65.7 KB
    1. Install the Tftpd32 /Tftpd64 on your computer based on the system type(32bit/64bit), here we take Tftpd32 as an example ;
    Download link: http://tftpd32.jounin.net/tftpd32_download.html

    2. Download the proper firmware of Pharos CPE products, here we take firmware pharos_un-up-ver1-0-0-P25-[20140709-rel51929].bin of CPE510 as an example, then must rename the firmware as recovery.bin;

    3. Configure IPv4 address of your computer as, you can click Here to configure static IP for the computer.
    Firmware Recovery Procedure

    Connect your computer to the LAN port of CPE510 with an Ethernet cable and run the Tftpd32.exe, then navigate the Current Directory to the folder where recovery.bin is stored.
    Name:  002.png
Views: 11888
Size:  37.5 KB

    Power Pharos device off first. Press the reset button on CPE510 and then power it on. Hold the reset button for about 6-8 seconds and focus on Tftpd32.exe interface at the same time. When you see the file transfer progress bar appears as below, then you can release the reset button.
    Name:  003.png
Views: 11748
Size:  58.4 KB

    CPE510 will reboot automatically after the file transmission completed, please wait for a while until all the lights on CPE510 are flashing and then perform normally.

    After reboot you may follow this link to login the management page of CPE510 again.
    Name:  004.png
Views: 11716
Size:  74.7 KB

    1. Please only perform firmware recovery through wired connection.
    2. Tftpd32 exe/Tftpd64 exe should be compatible with the Operating System, Tftpd32 exe should work with 32-bit System and Tftpd64.exe should work with 64-bit System.

  2. #2
    Thank you Admin. for this info.
    It's highly recommended to place a switch between the PC and the CPE210. I have never been able to run recovery succesfully without the switch
    Edit: it is no necessary to place a switch, works 100% without it, Windows 7
    Last edited by danymarc; 07-28-2015 at 10:05.

  3. #3
    Members radvd is on a distinguished road
    Join Date
    Oct 2013
    Find an un-advertised feature

    I have read from the Russian forum (last year) that some other models support tftp recovery with their new firmware.

    So if my guess is not wrong, the PhaOS supports this feature from the initial firmware TP_PharOS_1.0.0_140709

  4. #4
    Yes it works from 1.0 to 1.3 firmware

    change firewall rules

    subir fotos a internet
    and dont forget to set your lan adapter, do not leave default
    Name:  ADAPTER 2.jpg
Views: 11346
Size:  65.7 KB
    Edit: Aug. 18-2015 this last screen about selecting the ip it's not needed, but doing so you make sure you had the correct settings, and does not necessarily work at first time, you need various tries, and once it does not work I never get it in Win 7 untill TFTP is closed and open again.
    Could never made it work in Win XP
    Last edited by danymarc; 08-18-2015 at 14:28.

  5. #5


    Edit: i
    Issue found. Own mistake. The RJ45-junction/connection piece on my roof for the extending the cable, was leaked with water unfortunately.
    Some of the contacts of the RJ45 were 'thermical attacked'... Plugs, connection piece and junction box changed,
    everything now running well... Sorry for bothering.

    i am running two cpe210's. It was running without any issues the last days, till yesterday i configured something wrong. Hence, i did a remote reset of one of devices.
    Currently its rebooting in 1/2min intervall, not possible to connect to the web interface. Somehow stucked/bridged.

    Its only shortly reachable, until he is doing another reboot.

    I tried to recover the firmware with tftp. The recover.bin is taken but after the device reboots he takes the recover.bin again per TFTP.
    In addition, he is taking the recover.bin as well, if i dont push the remote reset button.

    Any ideas?
    Attached Images  
    Last edited by sw2k; 09-21-2015 at 11:32. Reason: Solved, own mistake

  6. #6
    Quote Originally Posted by rudi View Post
    I did recover one of my CPEs using my ubuntu server running atftp server. No problem.
    according to this post, ubuntu server running atftp server recovers too

  7. #7
    If the TFTP server interface doesn't show any progress (didn't respond), it is most likely caused by your system firewall that block the connection to the TFTP server, so the CPE devices can't connect to your TFTP server.

    You can try to turn off the firewall before re-trying to recover the CPE devices.

  8. #8
    Junior Member michelinia is on a distinguished road
    Join Date
    Feb 2017
    TFTP server is not working for me. I had tried delta instead. Ita working like charm for me. Thanks

  9. #9
    Junior Member Skylab is on a distinguished road
    Join Date
    Mar 2017

    What is delta

    Quote Originally Posted by michelinia View Post
    TFTP server is not working for me. I had tried delta instead. Ita working like charm for me. Thanks
    Could you explain what delta is ?, and the Steps how you recovery the Firmware of the CPE210 with delta ?.


  10. #10
    Hi, I am trying this on a CPE210 v1.1, and after the recovery.bin is transferred successfully, it asks for a file vmlinuz. I tried googling before posting and the only relevant result I found was this:
    This describes the exact same thing, that occurs with my device. Do you have a suggestion on how to proceed?

  11. #11
    I forgot to mention - all lights remain on, after recovery.bin is transferred (so it seems no install, reboot occurs). If I turn it off and then on, only the POWER light is on. If I turn on TFTP, when the device is in this state (no matter how much time has passed since it was turned on) - it downloads recovery.bin again and asks for vmlinuz again.

  12. #12
    Members R1D2 is on a distinguished road
    Join Date
    Dec 2015
    Quote Originally Posted by jimmytaker View Post
    Do you have a suggestion on how to proceed?
    What firmware did you load? In which region you are? What is the byte count transferred using TFTP?

  13. #13
    Connection received from on port 4011 [16/03 07:27:19.543]
    Read request for file <recovery.bin>. Mode octet [16/03 07:27:19.543]
    OACK: <timeout=5,blksize=512,> [16/03 07:27:19.823]
    Using local port 49447 [16/03 07:27:19.823]
    <recovery.bin>: sent 9643 blks, 4936747 bytes in 2 s. 0 blk resent [16/03 07:27:21.708]
    Connection received from on port 3164 [16/03 07:27:24.831]
    Read request for file <vmlinuz>. Mode octet [16/03 07:27:24.831]
    File <vmlinuz> : error 2 in system call CreateFile Das System kann die angegebene Datei nicht finden. [16/03 07:27:24.831]

    Hi, this is a log from an attempt to transfer recovery.bin.
    The file is the most recent firmware: pharos-up-ver1-3-3-P9[20160705-rel52453].bin; I also tried with the older version: pharos-up-ver1-3-3-P4[20151215-rel5855].bin - same result. The byte count transmitted is the same as the file size.
    Before I flashed OpenWrt and then LEDE on it. I was curious to see how the custom firmware compared to the original. I found MAXtream to really offer better performance and wanted to go back to the original firmware. I am in Spain. I have 2 of these devices - one is an (EU) version - has (EU) next to the SN before the V1.1, the other one is not - the one that is currently bricked is NOT the EU one (SN is followed directly by V1.1).

  14. #14
    Members R1D2 is on a distinguished road
    Join Date
    Dec 2015
    Quote Originally Posted by jimmytaker View Post
    the one that is currently bricked is NOT the EU one (SN is followed directly by V1.1).
    The request for vmlinuz seems to come from the OpenWRT linux loader or a modified environment setting in the SafeLoader. Maybe it helps to use a serial connection to the CPE and looking into the config/environment of the CPE's SafeLoader. It should also have a command to manually execute TFTP recovery so you could see the error message in the loader. Press CTRL-B to enter the SafeLoader while being connected to the CPE by serial line, then search for a TFTP boot command. Other than this I have no idea and although I like OpenWRT I would not recommend to install it on a CPE for various reasons (MAXtream in PharOS is one of those reasons).

  15. #15
    I would try that, if I had a cable, but I do not. And besides this other guy on the openwrt forum writes that he tried it and Ctrl-B would not work. Since my problem appears to be exactly the same as his, chances are, it will not work for me either. I just ordered 2 more of the same device. I will leave them with the original firmware and not install anything custom on them. The one I still have working with LEDE will just sit around and wait for some other use in the future - no need trying to revert it back to original and risk bricking it too. It works fine with LEDE.

    If somebody has another suggestion - please, or I get bored and decide to buy a cable and try connecting via serial, I will post the result.
    Last edited by jimmytaker; 03-17-2017 at 10:41.


Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts

Copyright 1996-2018 TP-LINK Technologies Co., Ltd. All rights reserved.