Welcome to TP-LINK Tech Support Forum
+ Reply to Thread
Page 1 of 3 1 2 3 LastLast
Results 1 to 15 of 42
  1. #1

    SOLVED- connection internet fail TL- WPA4220KIT

    Region : Spain

    Model : TL-WPA4220

    Hardware Version : V1

    Firmware Version :

    ISP : ONO

    Hi all,

    I had a problem and wanted to explain as I have resolved

    The problem I had with TL- WPA4220KIT powerlink but I must say I had the same problem with a tp link wr850re (which I returned )


    No wireless internet connected to TL- WPA4220KIT

    Network icon with message " limited access" and " Unidentified Network " ( http://support.microsoft.com/kb/2423416/es )

    Result Windows network diagnostics :

    The default gateway is not available
    The connection between your access point , router or cable modem and the internet does not work

    What happened to me was that from the pc that is connected by ethernet to the PLC work properly and the tablet but also the laptop when connected by wifi to the coverage area of ​​the TL- WPA4220KIT is properly connected to the ap but was left without internet
    AP but could not browse or ping to the gateway or not the tp- link. However if I was to the coverage area of ​​the main internet router had SI .

    First I thought it could be due to the fact that I did not have my main router WPS button and the process of cloning WIFI did more than just put the same SSID and password as the original ( that 's enough by the way ... )

    Then I thought to my main router did not like that redirigieran traffic from the tp -link but eventually the key was to change wireless card. (in my case change drivers )

    Probe to put another wireless laptop card and run at all at first . ( alfa AWUS036NH network )

    My lenovo s10 -3 laptop I have for months with windows 8.1 and have drivers that detected in the installation of windows .

    It has a broadcom card signed by microsoft dated 2013. With these drivers it worked properly with my router NETGEAR CG3100D .

    It's an old laptop and the latest drivers for your page is about the year 2010 that are signed by windows 7 broadcom http://support.lenovo.com/en_US/down...DocID=DS007967

    Now my laptop is running smoothly with these drivers windows 7 broadcom 2010 with TL- WPA4220KIT . ;-)

  2. #2
    I cannot understand.
    Daviz, have you identified what is the cause of WiFi client devices not being able to get DHCP settings from the 4220?

  3. #3
    In my case I had no internet.

    Did not work with DHCP. Nor with fixed IP

    Update the drivers for the laptop wifi card and everything ok.

    I currently have dhcp enabled on the main router that offers the laptop, the tablets and smartphones.

    The computer goes with ethernet tp-link repeater

    The ip dhcp server was successful but had no internet.
    Not ping the gateway, not ping tp-link repeater.
    Is properly connected to the network SSID but had no internet

  4. #4
    hey everybody

    i have the same issues ...
    i just dont understand the solution!

    i mean, i can update network card drivers on laptops but not on iphones (mobiles) and tablets!
    so i still have the problem that my mobile shows full wifi signal but is not able to connect to the internet!

    so ... i dont think this is solved

  5. #5

    Angry I am having the same issue as well.

    I am having the same problems as everyone. Still unable to come up with a solution even after talking to the technical support desk.

  6. #6
    I have got the same problem on my MACBOOK Pro and even all cellphones. I have got the WPA4220KIT for a couple of months and its starting to be pretty annoying when there's no internet available for some time. By disabling and enabling the WIFI connection on the laptop the internet connection is restored!

  7. #7
    same here... there is a similar threat about Internetconnection problem. (look for DHCP connection problem)

    somehow TP-LINK is not able to reproduce the problem, a lot of other users have. they don't even answer forum messages ;(
    very bad service here

  8. #8
    Same problem here guys. No solution so far. TP-Link Help!

  9. #9
    I have a temporary solution to this.It's not pretty but see here:


  10. #10
    Registered here just to add to the number of users experiencing this.
    So am I!

  11. #11

    Not solved

    Hi Admin,

    Please change this to not solved : this issue is still affecting many people and saying it is solved is misleading

  12. #12

    Not solved

    I think I'm having the same problem - powerline adapters work with Ethernet cables but no wifi? This is very frustrating having spent quite a bit of money on 3 of these things - what a complete waste of money.A

  13. #13

    not solved

    Hi, I am experiencing similar problems. My link was working fine for the last 9 months, but suddenly stopped yesterday. My home network is fine but there is no powerline network connection at all. I have moved power points for both bits of kit but I m no further forward. I ran the utility also, but it does not register any devices. Windows network configuration shows the wireless tp link but will not allow me any access at all to it. My mobile device registers the wireless but refuses to find an ip or connect with a manually assigned ip.
    Any help would be grateful.

  14. #14

    Thumbs up Ditto. My 4220 likes to go to sleep ???

    As reported by many users (on other forums as well) the 4220 likes to go to sleep at its own discretion. I've given up on it and do not recommend using it. Poor design.

  15. #15

    Same issue here, but now working

    Told my brother to buy these (he is in France, which makes it even easier - not!!) and he followed the instructions precisely, but could not get internet connection from the extenders. He isn't technical, but quite competent. So,now I am at his house, and he has done everything correctly. The extenders are fine with a wired connection, but would not allow internet connection over wifi. Got fed up, went to bed... tried again today - guess what? Working perfectly!

    I would really like to understand what is going on here, as I don't know what to tell him to do if it happens again.


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts

Copyright 1996-2018 TP-LINK Technologies Co., Ltd. All rights reserved.