Welcome to TP-LINK Tech Support Forum
+ Reply to Thread
Page 5 of 7 FirstFirst ... 3 4 5 6 7 LastLast
Results 61 to 75 of 92
  1. #61
    Actually my two 4220s had the same address when they stopped working, they did not pick another address, at least after a few hours.

  2. #62

    Totally unsuitable

    I think we can conclude that TL-WPA4220KIT is totally unsuitable to use in a wireless context. The company should remove that "functionality" and reference to it in their marketing.

    It works just fine as a powerline adapter, but when it comes to wireless, it is a pure hack, conforming to no known standard technology, and is unlikely to work in conforming installations.

    Too bad. But, as I said, using it with cables works just fine.


  3. #63

    Angry Another one here...

    I've had a triple AV500 setup for the last month or so. I'm getting the same issues with DHCP calls not being passed to the router (well, that's my take on it). It's particularly a problem with my sons Macbook, so last night I bound the IP address of that to the MAC address in the router - after a while it appeared to work, but I'm not holding out much hope for long term reliability after reading this forum!

    It looks like TP-Link aren't interested in this is an issue, does anyone else have any experience of a competitor product that DOES Work reliably?

  4. #64

    Thumbs up Yet another one

    I've just discovered that my TP-WPA4220 are the cause of all the intermittent network issues I've been having since I bought them a few months ago. In retrospect I should have realised this sooner, but when I tested them on day one they worked beautifully!

    My whole set of TP-LINK kit will be going back to Amazon as faulty for a refund. It's a shame as the powerline ones seem reliable, it's just the wifi ones that are the problem. I'm frankly shocked at how poor the firmware is.

    A friend has a netgear XAVN2001; apparently that is reliable.

  5. #65
    Seems odd that my WPA4230P shipped with default of IP of
    I think that would put it in coflict with most home routers ?
    I set address reservation of for mine and it seems to be working okay for wired clients, but my router is telling me there's a bunch of clients in the 192.168.0.x range.
    Is this normal ? BTW I turned Radio off.
    Name:  Capture.PNG
Views: 4871
Size:  9.3 KB

  6. #66
    Quote Originally Posted by Grindlay View Post
    Seems odd that my WPA4230P shipped with default of IP of
    I think that would put it in coflict with most home routers ?
    These units don't have a default IP - they listen to the network traffic and figure out what IP range is in use on your network - then they pick a random IP in that range that they believe is unused. This behaviour seems to be one of the ways these units misbehave.

    (I've returned my WPA4220 to Amazon as faulty now, got a refund and replaced them with TRENDnet TPL-410APK instead. These seem to behave better.)

  7. #67
    I have just bought a TP-Link WPA4226KIT from Currys, which I can get to work fine using my home Sky Fibre.

    I am no good at all these TCP, DHCP things, and fuddled through to get it to work.

    Had to use their own software to work out IP of the wifi part to log in to it to changes its SSID and p/w and also its deftault login username and password.

    What I can't get it to do is work with my Chromecast.

    The Chromecast can log in to the wifi but then I can't seem to cast to it from the devices I have?

    Is this down to this DCHP issue?

    Is there a fix for this or have I to take it back to Currys?



  8. #68
    Quote Originally Posted by jogu View Post
    These units don't have a default IP - they listen to the network traffic and figure out what IP range is in use on your network - then they pick a random IP in that range that they believe is unused. This behaviour seems to be one of the ways these units misbehave
    Weird that mine picked the IP address of my router and sparked an address conflict but there you go.
    I also think I figured out the cause of the 192.168.0.x addresses - I believe I'm connecting to my neighbour's powerline device(s). I googled it and it seems fairly common for RF signals to propagate out if your fusebox is not filtered for RF (few are, apparently).
    So my devices are getting their IPs from my neighbour's router via DHCP. I only realised this when I put into my browser and got his router admin screen.
    I've yet to determine whether pairing my powerline devices will fix this. Hopefully it will.

  9. #69

    IP connection problems

    I don't know if there is now a solution for this problem. I cannot access the internet through my powerline wpa4220 as it will not hold an IP address compatible with my router. My router is and the powerline has an address 169.xx.xx.xx which I cannot change with the utility. I need a wifi extender as I cannot change the location of the router. Can anyone help please?

  10. #70
    Shocking that TP-Links continue selling a products that does not work with know problem!!!!!! I am paking up this junk and sending it back and will replace it with a D-Link PowerLine AV 500 Wireless N Mini Starter Kit DHP-W311AV It looks to be the right one https://www.youtube.com/watch?v=pP8Tw1dbNEA

  11. #71
    TP-Link support just gives me the run around with braind dead answers. I am so disappointed

  12. #72

    possible solution

    Hi all, I have a possible solution where you don't need to assign any static IP-addresses to anything.

    I had the same problem as the topic starter: when I try to connect on the wifi-network when I'm in the zone extended by the TL-WPA4220 I do not get internet access and when checking the network details I see that an IP-address in the 169.x.x.x, subnet has been assigned, while the rest of the IP-addresses is in the 192.168 range. At that point, internet stops working on all my devices connected to the network and I have to reboot my router to get it to work again.

    This problem started when I updated the firmware of my router (Fritz!Box). Before that I had this network set-up working for 5 months, so first I thought it was the routers new firmware's fault. Then I spend about 6 hours over 3 days trying to solve it with downgrading the firmware of my router, restoring factory settings, upgrading firmware of both the router, WPA4220 and PA4010, restoring my routers back-up settings from before this all started, and several combinations and repetitions of this. In the end, when I almost threw the kit away due to frustration, I got it to work, so let me share with you what my steps were.

    Try this:
    1. Make sure the WPA4220 and PA4010 are paired and connected to the router, and that WLAN on the WPA4220 is TURNED OFF (by manually pressing the WLAN button for 5 seconds, the light should not blink but be off.)
    2. While your computer is connected to the WPA4220 via ethernet, run "
    Powerline Scan.exe" and click "connect" (called "TL-WPA4220_V1_Powerline_Scan_Utility", see http://www.tp-link.com/en/download/T...1.html#Utility)
    3. Manually turn on WLAN again, it should now work.

    I think these are the most essential steps of what I did. Since I actually took some more steps before it all worked again, I am not sure the above 3 steps are enough, so if this doesn't work directly, try the longer solution which I will describe below. (I do not want to disable my network again to try it for myself, since I don't want to risk spending so many hours on this again so please let us all know if this solution works if you are having these problems as well).

    These were the steps I actually took after which it all worked properly again:
    1. Factory reset WPA4220 (and the router, but this might not be necessary), and upgrade the firmware of the PA4010 and WPA4220 (and of the router, in my case Fritz!Box) to the most recent ones. (firmware TL-WPA4220_V1_160421 and TL-PA4010_V1_130821) I used the most recent tpPLC_Utility for this by installing the "PowerLineUtility.msi" file.
    2. Connect your computer via Ethernet to PA4010 to assign the right network name that you will also use for your WPA4220. Take the PA4010 out of the socket.
    3. Now put in the WPA4220 and connect your computer via Ethernet to assign the same network name and also put in the settings for your WiFi network (SSID, etc.), using also "Powerline Scan.exe" (see above). IMPORTANT: Turn off WLAN of the WPA4220 by manually pressing the WLAN button for 5 seconds, the light should not blink but be off. Then disconnect the WPA4220 from the socket.
    4. Put the PA4010 in a socket and connect it to your router and put your WPA4220 in the socket where you want to set it up. Connect your laptop through Ethernet to see if internet is working (it should). Check your router settings page to see what devices of the TP-LINK set are connected to your router (note the MAC-addresses)
    Do not yet turn WLAN on!!
    5. Run
    "Powerline Scan.exe" and click on "connect" to go the the settings page of the WPA4220. Doublecheck if the WiFi network settings are still correct (it should be), but you don't have to do anything. Now check your router settings page again, a new device connected to your router should have popped up. (it did for me as soon as, and then only, I ran "Powerline Scan.exe", the device then stays connected for a while, but after 20 minutes to an hour it disappears again from the list of connected devices)
    6. Turn on WLAN of the WPA4220 by manually pressing the WLAN button for 5 seconds.
    7. Wait a little while (I did for half an hour, not sure if this matters anything)
    8. Now connect your phone and other devices, they should again receive IP-addresses in the correct range. (it did for me)

    So somehow, it seems by running the "
    Powerline Scan.exe", you trigger a program in the WPA4220 that probably plays a role in assigning the right IP-addresses for WLAN. At least that's my conclusion from all this.
    In the end I have a total of 4 different devices (each with its own MAC address) related to the TP-LINK KIT in the history of the connected devices list of my router. I guess 1 of them relates to the PA4010 and 3 to the WPA4220, of which 1 only gets activated by running "
    Powerline Scan.exe"

    I hope this helps, please let us know if this does the trick for you as well.

  13. #73
    Okay, I just found out the 4th MAC address is not linked to the TP-link kit, but is from a tablet I thought was turned off and connected automatically what I didn't notice. So forget the part about a new MAC-address popping up when you turn on the WLAN manually, I think that was just a coincidence on my end.

  14. #74

    thanks evanA


    Thanks a lot for the solution it worked (short version).

    The network:
    WAP4220 kit with two extenders
    Extender1: WiFI on channel 5 same SSID as the router, static IP outside router DHCP range;
    Extender 2: WiFI off. static IP outside router DHCP range
    Router: WIFI on channel 3;

    Extender 1: IPAD + several windows mobile 10 + Several android + windows 10 laptop
    Extender 2: Bravia TV connected by cable
    Router: Windows 10 PC connected by cable + IPAD + several windows mobile 10 + Several android + windows 10 laptop

    The mobile devices roam between extender 1 and router;

    The problem:
    Windows 10 laptop got limited connectivity after lease time, however if the extender 1 was dsconnected and connected again it worked until next lease time. An ipconfig /release /renew had the same effect as lease time (of course).
    Don't know why only got problems with Windows laptop,

    besides the fixed extender IP had to perform evanA short procedure.

    Now I have everything working for 24H with no problem.

  15. #75
    The wpa4220 will assign itself the static ip by default. Plug in one wpa4220, plug a computer into the Ethernet port, and go to that address to access the wpa4220. I think the default user is admin and password is admin. Your router usually has a self-assigned static IP address like In that case I would assign the wpa4220 a static ip of, and if you have more than one wpa4220, continue with and so on. Be sure to save changes and I think it will have to reboot, then manually go to the wireless page and configure the wireless on the wpa4220 to match the router (but use a different channel).


Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts

Copyright 1996-2018 TP-LINK Technologies Co., Ltd. All rights reserved.