Welcome to TP-LINK Tech Support Forum
+ Reply to Thread
Page 6 of 7 FirstFirst ... 4 5 6 7 LastLast
Results 76 to 90 of 92
  1. #76
    Hi All!

    Wow Deployed a good number of the WPA4220 model and earlier models and never encountered this problem! EvanA's solution resolved for me. Just in case anyone has my scenario here's what I encountered...........

    Ok so client wants to expand Wi-Fi around public building for staff and maybe public access. Keen to use PowerLine kit.

    In my office testing I have existing TL-PA411 & TL-WPA4220 V1.0 set up with a TP-Link router model TD-W8980
    I had to hand a TL-WPA281KIT V3 comprising of TL-PA211 & TL-WPA281 V3.0 units

    My idea is to enable port grouping on the router (IE port based VLAN)

    Ports 1-3 default IP Pool 192.168.1.x Default DHCP start at .100
    Port 4 new public group IP Pool 10.44.0.x Default DHCP start at .100

    Configure existing TL-PA411 & TL-WPA4220 with a power-line network name EG Staff
    Configure spare TL-PA211 & TL-WPA281 with power-line network name EG Public

    Then the TL-PA411 would be in say port 2 of the router and be part of the 192.168.1.x subnet
    and the TL-PA211 would be in port 4 of the router and be part of the 10.44.0.x subnet

    Set port group on the router up ok.

    The TL-PA411 & TL-WPA4220 kit is up and running and has been for months the TL-WPA4220 had an IP set of 192.168.1.3 all good!

    Here's where my day goes downhill........
    Got the TL-WPA281 out and grabbed the 1st powerline utility disk I had to hand (not necessarily the one that came with the TL-WPA281 unit!)

    As soon as I ran the Powerline scan utility I found I could NOT set the IP address of the TL-WPA281 unit and make it stick!
    Ok so lets check out the existing, working TL-WPA4220 unit I think. Low and behold this has reverted to some random IP address out of the 193.168.1.x DHCP pool!

    Today Following EvanA's solution seems to have resolved it.
    I turned all PowerLine units off and apart from setting the Powerline Network name EG STAFF or PUBLIC I set the IP address of the TL-WPA4220 to 192.168.1.3 and the TL-WPA281 to 10.44.0.3. with the Wi-Fi of the powerline adaptors OFF!
    With all plugged in and re-booted I new have two separate networks via the PowerLine and two separate subnets. Hurrah!
    Access the PowerLine Wi-Fi Adaptors via there IP address above with Browser, NOT the PowerLine Scan utility, and turn on their respective WiFi All good! Big Hurrah!

    I will test for a few days to see if these settings all 'stick' as I intend!

    I conclude that with Wi-Fi on, the version of the PowerLine Scan utility I used was hunting the attached Wi-Fi subnet I'd initially started with or causing the Wi-Fi Powerline adaptors to do so (Smart Scan) IE 192.168.1.x (which will typically be the norm for most people or 192.168.0.x)
    It's just trying to be too clever! the old acronym KISS comes to mind!

    Another way to cope with this might be to assign some IP/MAC address assignments in the Router DHCP allocation pool. But that's boring! and in a large setup a pain!

    I'm did not have any to hand but I thought some of the very early versions of the TP-Link Wi-Fi and an option for Static IP. (Might be wrong!) but it's definitely something that would be very desirable in any future firmware updates please!
    Last edited by sjgnet; 11-29-2016 at 15:51.

  2. #77

    Cool wifi problem/dhcp/ios

    I bought TL-WPA4220 Powerline Extender connected to a TL-WPA2220Kit.
    I used to have wifi problems with WPA4220: connection dropping twice a day, broadcast/DCHP not assigning ip address, specially with IPhone and IMac (PCs and Androids less problems). Sometimes assigning static IP address would work (but not for more than 1 or 2 days) so I plugged another wifi router to the WPA4220 as a workaround.
    A few days ago, I realized that my firmware (v1-EU) was not updated as I had thought. TPLink download page in Brazil didnt have the latest firmware version, it shows April,2014. Visiting TPLink page in Portugal I found a new firmware dated May,2016.
    Both are same region v1(EU) and it worked for me. My problem is apparently solved.
    http://www.tp-link.pt/download/TL-WPA4220.html#Firmware

  3. #78

  4. #79

  5. #80
    Setting up a static IP was the solution and it allowed me to force an address outside the wifi/24. All clients were talking to DHCP just fine but the AP was invisible to scan probes! Whatever they have fixed it now refuse to accept my out-of-range ip and it now choose a random IP inside the wifi/24 instead. This bug was a exceptional feature, I was able to hide them all and I bought many because of it.It had a management interface, kind of, and now no more.

  6. #81
    The powerline extenders can't accept the static IP address assigned by the router.
    It only has a default IP 192.168.0.1 to manage it, if you are able to login to the management page, you can change it into the DHCP range of your router.

  7. #82
    Quote Originally Posted by uutommi View Post
    The powerline extenders can't accept the static IP address assigned by the router.It only has a default IP 192.168.0.1 to manage it, if you are able to login to the management page, you can change it into the DHCP range of your router.
    I probably wasn't clear enough. Before: I setup a 1.245/24 IP in the AP inside a VLAN where DHPC leases out 20.0/24. All great, AP was invisibile to discovery scans. Now: I do the same but the AP refuses to use an IP outside the 20.0/24. It works as it should but the AP is now, obviously, visible. I do not have problems, I'm just pointing out that after understanding the bug I was able to use it to add a tiny layer of security in my 802.1x WIFI. I would also need to add that using an IP inside the DHCP range is wrong as this may cause duplicate IPs. Instead you all should use an IP outside the DHCP range but still inside the subnet. Cheers.

  8. #83
    I also have this problem too. So I have call technical staff to settle it. Now It is ok

  9. #84

    Angry Avoid this product

    I bought the WPA4220T kit in 2015, containing one PA4010 adaptor and two WPA4220 wifi extenders. My home router uses 192.168.1.1 as its IP address. Since the day I bought these things, I experienced network issues. The internet would stop working for all of the devices on my home network (at the same time). I complained to the ISP, I changed the home router ... and finally I worked out that the WPA4220s were causing the problem.

    The WPA4220s need an IP address when they connect up to the network, but instead of using the DHCP protocol (like most other devices - phones, tablets, laptops, etc.) they just pick an IP address and go ahead and use it. In my case, often one of the WPA4220s was choosing 192.168.1.1 - i.e. the same address as my home router uses (and the address which every device on the home network uses in order to access the Internet).

    After I figured out that these devices were actually breaking my network, I disconnected them and put them away. I just took them out of the cupboard (over 2 years later) and updated them all with the latest firmware ... but nothing has changed, and one of the WPA4220s promptly decided to use 192.168.1.1 and when it did it immediately broke internet access from my home network.

    This is a fundamental design issue. The workaround suggested earlier in this thread is good if the devices power up (without knowledge of the IP range in use, so they operate somewhere differently and don't interfere with other devices) ... except that after a power cycle for the devices most likely all bets are off and they will randomly pick new addresses.

    Failure to adhere to standards such as DHCP lead to my recommendation to AVOID THIS PRODUCT. TP-Link could fix this if they want, but given the amount of time which has passed since this product launched, and the continued existence of this thread, it seems safe to assume that they don't care.
    Last edited by caveman; 04-05-2018 at 09:21.

  10. #85
    Hi All,


    TP-Link is aware of this issue. Following our research and investigation, we found that this issue due to some routers' default LAN IP is 192.168.1.1 which is the same as the TL-WPA4220_V1 default IP. So there will be IP address conflict when you first setup or reset the TL-WPA4220_V1. ( Our TL-WPA4220 will change its IP address after detecting IP address conflict, but there still will be a short IP address conflict. )
    In order to help these customers who are affected by this reason our R&D have made a beta firmware ( TL-WPA4220_V1_180509_Beta ) to change the TL-WPA4220_V1 default IP from 192.168.1.1 to 192.168.0.254.
    You can visit our official website try to download and upgrade the latest beta firmware to resolve this issue.

    Note: After upgrading this firmware, you need manually reset this device to make it work.

    For TL-WPA4220(EU/UK)_V1 : https://www.tp-link.com/en/download/....html#Firmware

    For TL-WPA4220(US)_V1 : https://static.tp-link.com/2018/201805/20180510/TL-WPA4220(US)_V1_180509(beta).zip




    Last edited by TP-Admin; 05-14-2018 at 08:48.

  11. #86
    I pretty much believe this patch won't help, as this issue keeps happening even after changing subnet settings... however I found this somewhat useful as I can hide the AP from the VLAN, i give it a static IP outside the subnet while still allow me to serve wireless devices on the correct subnet

    By the way .254 is often taken... the fix should be to boot up a working DHCP first
    Last edited by caiordo; 05-10-2018 at 16:21. Reason: line break

  12. #87
    With the current firmware you just assign a static IP outside your router DHCP pool (so no IP conflicts), reboot and that is it.

  13. #88
    TP-Admin what about hardware version TL-WPA4220 v3.0 with firmware version 3.0.2 Build 20170725 Rel.69019 ? Is this fix included in this firmware ?
    Thanks

  14. #89
    tp-admin what about hardware version TL-WPA4220 v3.0 with firmware version 3.0.2 Build 20170725 Rel.69019 ? Is this fix included or shoul I get another version (that i dont see in your firmware page)

    Thanks

  15. #90
    Hello,

    I have updated to this beta and now I cant pair my device anymore, how do I downgrade it ? the last files before this beta are
    MAC-7420-v1.3.1-00-CS.nvm
    and
    4220_10_en50561update.pib

    not BIN file like the beta firmware, so i cant downgrade

    before updating to beta i noted exactly the firmware i was into:

    Firmware Version:
    1.2.8 Build 140401 Rel.49960n
    MAC-QCA7420-1.3.0.2134-00-20151212-CS
    PIB_422091_160421_003
    Hardware Version:
    WPA4220 v1 08C84015


    HELP please!


 

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts

Copyright © 1996-2018 TP-LINK Technologies Co., Ltd. All rights reserved.