Welcome to TP-LINK Tech Support Forum
+ Reply to Thread
Results 1 to 2 of 2
  1. #1
    Junior Member SurgeonX1 is on a distinguished road
    Join Date
    May 2018
    Posts
    1

    UH 720 Lots of misfunctions ! Crap device !

    Model :

    Hardware Version :

    Firmware Version :

    ISP : [/COLOR]

    1. Sometimes after restart of Win 7 power is off, should be on ! if the power button is not used !

    2. Often usb-sticks connected do not appear in windows, must be disconnected and new connected.

    This device for 50 is crap ! I tried other 7 port hubs, they have other faults.
    You must pay 100 / 100 $ to get a good one without defects !
    Problem are the chips inside, at 7 port hub you need more than one and according to experts this is the problem so they recommend only buy 4 port hubs.

    I see the issue here again.

    The device has only 3,3 A, much too less for 7 ports plus 2 ports for current.
    USB 3.0 has max. 900mA for each port, so you need at least 5 or 6 A.
    The producers always want to save money,
    And the power supplies about 5 or 6 A you have to pay only about 50 or $ for !
    Beside that the chip problem is separate from that / malfunction of some ports as mentioned above.

    For me it is a cheap china product !
    Loss of moral attitude is first sign of debility.

  2. #2
    I also have a UH720 while it's very convenient for me.
    Perhaps I haven't connected all the 7 USB ports, there is no any issue so far.
    One thing like you, it seems it will turn off sometimes even I didn't press button button on it.
    I am satisfied with it so far except that little issue.


 

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts

Copyright 1996-2018 TP-LINK Technologies Co., Ltd. All rights reserved.