Welcome to TP-LINK Tech Support Forum
+ Reply to Thread
Results 1 to 4 of 4
  1. #1
    Junior Member User4711 is on a distinguished road
    Join Date
    Dec 2017

    M7350 V3 suddenly stopped working/does not boot anylonger

    Model :

    Hardware Version :

    Firmware Version :

    ISP : [/COLOR]

    Model: M7350 V3.0
    Router was working one day, and since the day after it is no longer possible, to start the device.
    Pushing the power button results in screen showing TP-Link logo, but then it stuck.
    Tried to push internal reset button, but no change.
    Tried to remove battery for 24h+, but no change.

    Menu button does not work, most likely because the OS is not (fully) up.
    Also, device does not show up when being connected via USB cable.

    Warrenty has ended month ago or so, TP-LINK support did not respond to my email.

    Any suggestions?

    PS: searched the forum, but nothing seem to fit this situation

  2. #2
    try to recharge it? if still cannot power up, the device seems to be defective since reset doesn't respond as well

  3. #3
    terima kasih banyak

  4. #4
    Junior Member Warren is on a distinguished road
    Join Date
    Jun 2018
    did you win with your router. am having the same problem


Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts

Copyright 1996-2018 TP-LINK Technologies Co., Ltd. All rights reserved.