Welcome to TP-LINK Tech Support Forum
+ Reply to Thread
Results 1 to 12 of 12
  1. #1

    TL-WA850RE Invalid Password Error

    Model :

    Hardware Version :

    Firmware Version :

    ISP : [/COLOR]

    Hi, I use a TD-W9970 v3 modem as host and TL-WA850RE V4 range extender with factory settings.

    After quick installation, I changed the SSID of the extender and can connect it with my iPhone. However, when I try to connect it with my MacBook Air (Version 10.12.6), it gives invalid password error although the password is correct. Please help me about this problem.

  2. #2

  3. #3
    Thanx for your reply. Instead of Quick Installation, I tried to adjust the settings manually and after I selected WPA-PSK/WPA2-PSK as wireless security, It worked

  4. #4
    good news!

  5. #5

    TL WA850RE Invalid Password

    I have a SR10000 Range Extender off of a wifi router. They currently have similar SSID i.e. router and router_RE and the same security key password. If I update/change the key on the home will it also change it on the extender?
    Инкомторг-международная оптовая торговля Инкомторг-международная оптовая торговля...

  6. #6
    No, the extender will not update the key automatically.
    You need to reset the extender and reconfigure it.

  7. #7

    TL-WA850RE Invalid Password for MacBook

    hi

    I'm from Poland and have just bought this device and it works fine for HP Laptop, Sony Xperia Z tablet, iPones 6S, but it doesn't work for MacBook Pro. During connecting to this network as usual asks for password, but replies "Invalid Password".

    I've tried to change Security to WPA-PSK, WPA2-PSK and WPA-PSK/WPA2-PSK. The same issue.


    Firmware Version: 1.0.0 Build 20170609 Rel. 34153(6985)
    Hardware Version: TL-WA850RE v5.0

    Should I update firmware?
    I found this one http://www.tp-link.com/us/download/T....html#Firmware. Not sure it is suitable for my version.

    Thanks for your help!

  8. #8

  9. #9
    Iąve just upgraded from Build 20170609 Rel. 34153 to Build 20171218 Rel. 58240.
    The same behaviour: 'invalid password' on MacBook Pro, but it works fine on other devices.

  10. #10

    TL-WA850RE Invalid Password for MacBook

    Could anybody help with this?

    Thanks

  11. #11
    Junior Member pelelademaderda is on a distinguished road
    Join Date
    May 2018
    Posts
    1
    the problem is not only in macbook.

    I cannot connect to wireless over linux, with any of the usb devices I have... with windows I have no problem.

    I can only connect with a wire, and url dont report the pc connected...


    I have an WA850RE V4, I try with every firmware I found, with gentoo linux and ubuntu. It tells me invalid password.
    I use the same ssid for main lan in 5ghz and 2.4 ghz and repeater uses the same ssid.

    If I change the ssid of the repeater connection works, but thats not the point of a repeater, the objetive is not to be disconnected every time the signal fall

  12. #12
    Junior Member beornharris is on a distinguished road
    Join Date
    May 2018
    Posts
    1

    Same Issue for me

    Macbook Pro, late 2011 with Sierra installed.I have 3 TP-Link WA850RE all configured identically (with no problems from any other household device)When configured as OPEN, the MBP can connect, but with WPA/WPA2 Personal - no dice.I have done all macbook troubleshooting tricks I can find.A solution would be greatly appreciated!


 

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts

Copyright © 1996-2018 TP-LINK Technologies Co., Ltd. All rights reserved.