Welcome to TP-LINK Tech Support Forum
+ Reply to Thread
Page 1 of 2 1 2 LastLast
Results 1 to 15 of 17
  1. #1

    Archer C3150 V1 Beta Firmware update

    Model :

    Hardware Version :

    Firmware Version :

    ISP : [/COLOR]

    I have been experiencing wifi dropping on my C3150 V1 router which was purchased in June of 2016. I worked with customer support to troubleshoot my problems and when we had exhausted all of the potential problem areas with no success, the representative sent me a link to a beta firmware update (number 170526). So far, after 4 days, my wifi has remained stable. There is a watermark on my router interface now that reads "Confidential - Only for Test". I asked why this firmware has not been made available on the update page, since it has a May completion date. The representative did not know why.

    Has anyone else had this experience? I feel as though the V1 C3150's have been left in the dust vs. the V2's which have received several updates in 2017. If beta firmware update 170526 is stable, why hasn't it been released? And, if it is not stable, am I testing it for them?

    TP-link should provide support for the V1 routers, just as they do for the V2's.

  2. #2
    Members thexfile is on a distinguished road
    Join Date
    May 2016
    Posts
    12
    What's the link.
    Archer C3150 (US) v1 || Test Build 170526 Rel.67540n

  3. #3
    Following is what was sent to me on August 22nd:

    It actually appears that there is a beta firmware that should help with stability of the Wireless, please download and update and let me know if the stability problems persist:



    http://static.tp-link.com/Archer C3150(US)_V1_170526_Beta.zip





  4. #4
    Members thexfile is on a distinguished road
    Join Date
    May 2016
    Posts
    12
    Thanks. :-)

    It seems to work...
    Last edited by thexfile; 08-28-2017 at 22:39.
    Archer C3150 (US) v1 || Test Build 170526 Rel.67540n

  5. #5
    Hi. Support is not getting back to me...

    I know this FW says "US" but would it also work on a "EU" V1 router?

  6. #6
    No, EU and US cannot update to each other. You can email the tplink support

    Quote Originally Posted by Muyfa666 View Post
    Hi. Support is not getting back to me...

    I know this FW says "US" but would it also work on a "EU" V1 router?

  7. #7
    Quote Originally Posted by uutommi View Post
    No, EU and US cannot update to each other. You can email the tplink support
    I did, but there seem to be no EU firmware.

    Also, there seem to be no desire to provide one.

    Support keeps suggesting standard stuff like reboot my router, check if the internet connection is ok, try alternate DNS, etc etc...

    Oh well, I guess this router is a lost cause support-wise.

  8. #8
    Maybe they just want to locate your issue, you can follow their suggestions, they will give you a solution at the end.

    Quote Originally Posted by Muyfa666 View Post
    I did, but there seem to be no EU firmware.

    Also, there seem to be no desire to provide one.

    Support keeps suggesting standard stuff like reboot my router, check if the internet connection is ok, try alternate DNS, etc etc...

    Oh well, I guess this router is a lost cause support-wise.

  9. #9
    Oh well,TP-link should provide support for the V1 routers, just as they do for the V2's.

  10. #10
    I got my C3150 Dec 28th 2016 from Amazon,
    Firm: 0.9.1 0.1 v005f.0 Build 160603 Rel.61835n
    Im tired of having to reboot my Router. I had 4 previous Routers from TP Link and Never had this issue before. I use my Main PC as a Video server as well as to download large files.. during heavy traffic it crashes !!! Im tired of rebooting.,,, I use a ...EDUP EP - AC1621....Dual Band 1900M 2.4GH / 5.8GHz 802.11ac WiFi Dongle USB 3.0 4T4R MIMO technology on my Video server/PC...::::: and a USB 3.0 802.11AC Wireless WiFi Network Adapter Dual Band 5.8G 2.4G Up 1200Mbps on another PC ... the rest is phones for now.. I need resolution so I can use my Router as it was suppose to be designed to be used ... I dont remember reading on your website that it would crash under heavy traffic !!.. Please help or give me a RMA so you can repair, replace
    or even updated to V2 if that is the only way to fix this issue...
    Thanks Juny

  11. #11

    How to get TP Link issues resolved.

    This venue is simply a forum for users to post issues and/or ideas regarding their TP Link products. You need to contact TP Link Customer Service and get the process going to resolve your issue. They will assign your case a number and begin trying to resolve your problem. Be sure to follow all of the steps that TP Link recommends, even though they seem unnecessary. I followed their direction and in the end, they sent me the link to the beta firmware, which has been very successful for me. I have not had a wifi drop since I updated the firmware on Aug 22 of this year. If the beta firmware update had not worked for me, the next step would probably have been replacement, since I am still under warranty. I tried being forceful at first, demanding that I get a replacement, but I soon learned that to get anywhere, you have to go by their play book. If you want to try the beta firmware update, the link appears in one of my previous posts.

  12. #12
    Quote Originally Posted by halinh95 View Post
    Oh well,TP-link should provide support for the V1 routers, just as they do for the V2's.
    It would be nice if they did but it seems they've left V1 users in a ditch with multiple updates for V2 users.

  13. #13

  14. #14

    Link to Beta Firmware update for TP Link C3150 V1

    Here is the link that TP Link send to me back in August for the C3150 V1:


    http://static.tp-link.com/Archer C3150(US)_V1_170526_Beta.zip

  15. #15


 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts

Copyright © 1996-2018 TP-LINK Technologies Co., Ltd. All rights reserved.