Welcome to TP-LINK Tech Support Forum
+ Reply to Thread
Results 1 to 12 of 12
  1. #1

    Smile Share Label Changes on Archer-VR900 V2

    Model :

    Hardware Version : Not Clear

    Firmware Version :

    ISP : [/COLOR]

    After owning the router for a couple of weeks I've notice the volume label for the USB drive I have setup for sharing will sometimes have changed from sda1 to sdb1.
    Then sometime later it will revert back to sda1.
    Just wondering if this is normal or whether there is a problem somewhere.
    Anyone out there with an Archer-VR900 V2 using the share function?

    Last edited by JPM27; 01-15-2018 at 23:34. Reason: Have found a solution to the issue.

  2. #2

    Red face

    Hi JPM27,

    I've got the VR900v2 , I am using the USB port closest to the power button and not had any issues with it changing from sda1 to sdb1 , thats strange

    from my little knowledge of Linux it seems the USB is dropping the USB drive and then rescanning and finding it again , but not letting go of the first

    instance , that would explain the a and b on the sdx1.

    Here is a screen shot of what I have , have you checked your firmware is up to date , if you look at my screen shot the newest firmware is listed along the

    bottom of page as I did mine recently.

    Attached Images  
    UK TalkTalk VDSL customer on 80/20 Mbps line.

  3. #3
    Thanks for your reply Dave.

    Yes I did the firmware update, thinking maybe a bug was the cause but it still occurs.
    I might try disconnecting the drive and reconnecting to the other USB port to see what happens.
    Maybe with a small extension to get the drive and router farther apart, almost side by side at the moment.

    It's a little annoying as when it occurs the shortcuts I've set up on my computers to the folders inside; Doc's, Music, Pictures etc. no longer work.

    I'll try the above and see how it goes.

    John - JPM27

  4. #4

    Cool Try this it may help

    Hi JPM27,

    I would try removing drive , rescan and find no drive , also try the tick box in settings for USB interference reduction , then reboot router.

    wait and then install in other USB port and do a rescan , that should reset it .


    Attached Images  
    UK TalkTalk VDSL customer on 80/20 Mbps line.

  5. #5
    what if u assign a real volume name to the partition?
    and maybe even a partition name?
    maybe the device name does not matter then anymore...?

  6. #6
    Hi John,

    The way I do it , as Network Neighbourhood in Windows can be fussy , especially when you have Win 7 and Win 10 PC's on the Network

    is to simply add a shortcut to desktop and access it via http like this " " , this will not fix your sdx issue but

    it was my work around as I found that even using a shortcut for the VR900 via "Network " would open a window but would not show any

    sda1 folder on a regular basis .

    I suspect its Win 10 messing with " Network Neighbourhood " because if I try it without any Win 10's online it works pukka ?

    Last edited by Dink; 08-28-2017 at 11:37.
    UK TalkTalk VDSL customer on 80/20 Mbps line.

  7. #7
    Hello Dave.

    Don't seem to have a problem with the ARCHER link in Network, always takes me to the root folder, whether it's sda or b and I can always open it.

    Just Windows 10 and a couple of Android devices here.

    Probably going to jinx it now but for the last couple of days it has been quite stable as sda1...!

    I'll keep an eye on it and next time it switches see if I can identify a trigger and post back.

    Thanks for the advice and suggestions both.


  8. #8

  9. #9

    Solved, sort of.

    Sorry to resurrect a fairly old thread.

    Not exactly solved the sda1 / sdb1 issue I was having but have found a work around.

    I've disabled the "share all" setting in the VR900 and then individually selected each of the required folders to be shared .

    Then in the "Add a network location" option in Windows 10 created shortcuts as such; \\Archer_vr900\folder-name for each of the shared folders.

    So far this approach seems to be working fine.

    Thanks all, and if not too late HNY 2018


  10. #10
    Hi John ,

    Nice to see you seem to have got it under control

    The difference may be the fact that my sda1 opens straight to the root folder with files directly there and a few folders with files , you however seem to have a set of folders
    first then in each folder your files , so probably a bug in the firmware regards folders in folders in folders sort of thing .

    Or it may be a Win 10 issue that awakens the bug and Win 7 deals with it , as security in Win 10 is far more severe than Win 7.

    Its always good to get some feedback on this sort of thing after a bit of time has passed , this will help others that get the same issues in the future , even me if I get myself a
    bigger drive and start to need folders in folders .

    Last edited by Dink; 01-17-2018 at 00:00.
    UK TalkTalk VDSL customer on 80/20 Mbps line.

  11. #11

  12. #12


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts

Copyright 1996-2018 TP-LINK Technologies Co., Ltd. All rights reserved.