Welcome to TP-LINK Tech Support Forum
+ Reply to Thread
Results 1 to 4 of 4
  1. #1

    Network speed between two CPE220

    Model :

    Hardware Version :

    Firmware Version :

    ISP : [/COLOR]

    Hello,
    I would like to ask a couple of questions. Since the units are 300 Mbps, I am able to reach only 11 Mbps when the traffic is hot on the network(video streaming). If there is no load at all, it may reach 60 Mbps and in rare cases 90 Mbps. Is this normal? I am observing the "Negotiated Rate (Mbps)" but not sure what exactly is meant here.

    The distance between the units is just 100 meters in straight direction and perfect visibility (in the configuration I've set a distance of 0 km).

    Is there any advanced tutorial on how to boost speed?

  2. #2
    Members R1D2 is on a distinguished road
    Join Date
    Dec 2015
    Posts
    1,127
    Quote Originally Posted by penkomitev View Post
    I would like to ask a couple of questions. Since the units are 300 Mbps, I am able to reach only 11 Mbps when the traffic is hot on the network(video streaming). If there is no load at all, it may reach 60 Mbps and in rare cases 90 Mbps. Is this normal? I am observing the "Negotiated Rate (Mbps)" but not sure what exactly is meant here.
    Negotiated rate is the rate the two CPEs have negotiated to (agreed to use). It is always changing b/c the devices negotiate speed according to the load.

    First you should differentiate data speed (traffic on the LAN port) and wireless speed (traffic over the air). Data speed is limited to 100 Mbit/s on the CPEs, because they use a Fast Ethernet (100BASE-T) interface. So, 90 to 93 Mbit/s is normal, yes. Since Fast Ethernet is full-duplex, you can transfer up to 180 Mbit/s over the wire at the same time (90 Mbit/s per direction). To get 180 Mbit/s over the air, the unit needs a higher speed since a) the CPE can't allocate the radio channel all the time and b) wireless transmission is half-duplex. Since only one device can allocate a WiFi channel at any given time, the CPE uses free time slots to send data. If it sends data, the other CPE listens to it. If the other CPE sends data, the local station listens to it. The time slot the CPE can use the channel to send data is called its "AirTime". Since AirTIme must be limited for each device, the data has to be sent much faster than it arrives on the wire. That's the reason why CPEs send/receive with up to 300 Mbit/s.

    The distance between the units is just 100 meters in straight direction and perfect visibility (in the configuration I've set a distance of 0 km).
    Set it to Auto or to 0.1 km for best results.

    Is there any advanced tutorial on how to boost speed?
    First, if you use the CPEs in PtP mode, set fixed 802.11n wireless mode. For the CPE2x0 set channel width to 20 MHz. 20 MHz will allocate 4 channels, while 40 MHz tries to allocate 8 channels on the 2.4 GHz frequency band. SInce you only have 3 non-overlapping channels (4 in 802.11n mode), which are shared with all your neighbors, reduce channel width, except if there are no neighbors nearby.

    At a distance of 100m you could fiddle with TX power to see wether it will increase speed on heavy loads. Lower the TX power and watch the SNR on the Status page. Find the TX power which gives best SNR result.

    You could also turn on MAXtream on the AP to test wether it performs better on high load.

    But of course it is totally normal that speed drops in a speed test if a video stream is received simultaneously. Part of the bandwidth will be consumed by the video stream. You have to add this to the speed test results to get meaningful values.
    Last edited by R1D2; 08-24-2017 at 01:07.

  3. #3
    Thank you @R1D2 for the very detailed answer, it was very helpful and solved my problem.

    In fact, changing the following things really improved the connection between the units and it could be observed not in terms of speed values, but directly from the video streaming quality. I don't see any lags, shake of picture, etc anymore:
    * Adjusting the distance to 0.2 km (it used to be 0)
    * leaving only the 802.11 N (it was b/g/n mixed before)
    * leaving only the 20 MHz channel (it was 20/40 before)
    * setting WIFI channel 6 fixed (my other router is at channel 1 and the third one in the other building at CH11. These are the three non-overlapping channels.) - it was "Auto" before.

    Now the max TX speed is fixed to 144 Mbps but the negotiated speed is almost always 144 Mbps or at least 100+ and really - it improved a lot now. I think the Signal reduced to -66 from around -85 and I believe it is due to the 0.2 km setting.
    Last edited by penkomitev; 08-25-2017 at 07:41.

  4. #4
    Members R1D2 is on a distinguished road
    Join Date
    Dec 2015
    Posts
    1,127
    Well done, penkomitev, and thanks for feedback. Have fun with the CPEs!


 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts

Copyright 1996-2017 TP-LINK Technologies Co., Ltd. All rights reserved.