Welcome to TP-LINK Tech Support Forum
+ Reply to Thread
Results 1 to 4 of 4
  1. #1

    TL-SG5428 - Configuration for ESXi Virtual Switch Tagging

    Model : TL-SG5428

    Hardware Version :

    Firmware Version : TL-SG5428_V1_150129

    ISP : [/COLOR]

    Hi,

    I'm trying to set up my TL-SG5428 switch for ESXi Virtual Switch Tagging:

    https://kb.vmware.com/selfservice/mi...rnalId=1003806

    I configured 3 VLAN's in the switch and tried to implement the port configuration according to the KB from VMware...unfortunately not successfully. According to the example in the KB, which would be the equivalent commands for the following two CISCO commands?

    switchport trunk encapsulation dot1q

    spanning-tree portfast trunk

  2. #2
    Try this lines for
    • create three VLANs
    • name the three VLANs
    • bind the three VLANs to 3 three separate Ports, so you connect a device without VLAN-Support
    • bind all three VLANs to Port 4 to connect a device, which support VLANs

    Code:
    vlan 10,20,30
    #
    vlan 10
    name "mgmt"
    #
    vlan 20
    name "intra"
    #
    vlan 30
    name "dmz"
    
    interface gigabitEthernet 1/0/1
      switchport access vlan 10
      description "Management"
    #
    interface gigabitEthernet 1/0/2
      switchport access vlan 20
      description "Intranet"
    #
    interface gigabitEthernet 1/0/3
      switchport access vlan 30
      description "DMZ"
    #
    interface gigabitEthernet 1/0/4
      switchport mode trunk
      switchport trunk allowed vlan 10,20,30
      description "Trunk all VLANs"
    #
    You have to do this in configure mode.

    Good luck
    Ulf

  3. #3
    Hi Ulf,

    thank you for your input.

    I have actually done these steps already in config mode. Based on the description from VMware, after configuring these steps, the following two CISCO commands should be also entered:

    - switchport trunk encapsulation dot1q

    - spanning-tree portfast trunk

    My "problem" is to find/understand the equivalent commands for the TL-SG5428 switch. I read the CLI manual, but I am not sure which TL-SG5428 config-commands would do the same as these previous two commands for CISCO switches. Any idea?

    Regards,
    Steve

  4. #4
    Hi Steve,

    "switchport mode trunk" on the TP-Link is the same like "switchport trunk encapsulation dot1q" on CISCO. Perhaps Cisco can also port pased vlans.

    For spanning tree I set this one time in the global configuration mode and on every interface, which could be affected:

    Code:
    #...snip
    #
    ip ssh server
    no ip ssh version v1
    #
    #
    spanning-tree
    #
    snmp-server
    #...snip
    ip ssh server
    no ip ssh version v1
    #
    #
    spanning-tree
    #
    snmp-server
    #
    #...snip
    #
    interface gigabitEthernet 1/0/3
      description "Trunk SW001"
      switchport mode trunk
      switchport trunk allowed vlan 10,20,30,40,50,60,70,21,41
      switchport trunk allowed vlan 30
      switchport pvid 10
      spanning-tree
    
    #
    interface gigabitEthernet 1/0/4
      description "Trunk SW001"
      switchport mode trunk
      switchport trunk allowed vlan 10,20,30,40,50,60,70,21,41
      switchport trunk allowed vlan 30
      switchport pvid 10
      spanning-tree
    
    #
    #...snip
    This this configuration there is noch network storm anymore between this two switches.

    Good luck.
    Ulf


 

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts

Copyright 1996-2017 TP-LINK Technologies Co., Ltd. All rights reserved.