Welcome to TP-LINK Tech Support Forum
+ Reply to Thread
Results 1 to 3 of 3
  1. #1

    Printer Connection via USB

    Model :

    Hardware Version :

    Firmware Version :

    ISP : [/COLOR]

    You can’t use this version of the application “TP-LINK USB Printer Controller Installer” with this version of macOS.

    I am using version
    10.12.5...

    No idea how to fix this?

    Thanks in advance.

  2. #2
    have you tried this one? http://www.tp-link.com.au/download/A....html#Utility( for mac 10.12)
    if it is the same, it's suggested to submit a ticket to TP-Link support.

  3. #3

    Thankyou

    Thanks Kevin, I will give that a try./


 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts

Copyright © 1996-2017 TP-LINK Technologies Co., Ltd. All rights reserved.