Welcome to TP-LINK Tech Support Forum
+ Reply to Thread
Results 1 to 6 of 6
  1. #1

    Exclamation TD-8810 issue with web servers virtual hosts and NAT

    Model : TD-8810

    Hardware Version : 1

    Firmware Version : 3.06L.03-T1.0a-091210.A2pB023k.d17m

    ISP : [/COLOR]

    I have a local machine with IP 192.168.1.10 which is running Apache web server with virtual hosts. I set port 80 forward to this machine. I'm using dynamic dns services, such as no-ip and freemyip.

    From outside my LAN, i.e from the Internet, The only host accessible is the default host, while any other virtual hosts are not accessible. Those virtual hosts are accessible only from my LAN or if I replace my TD-8810 with another router, I have another router model.

    I have gone to the support page of TD-8810 to upgrade the firmware, and I have downloaded the firmware titled TD-8810A_V4_091210
    in which the following fix is regarded:

    1. Fix a bug that virtual server can be accessed from WAN side if the service port is 80.
    Also, I disabled router's http service from WAN. However, the issue is still exist and I could not able to access my web server's virtual hosts. Is there any solution?
    Last edited by saidbakr; 07-14-2017 at 08:39.
    *********************
    Best Regards,
    Said Bakr.

  2. #2
    hi, does this router get an wan ip address from the ISP? what it is?

  3. #3
    Quote Originally Posted by Kevin SG View Post
    hi, does this router get an wan ip address from the ISP? what it is?
    It is not fixed IP. As I regarded in the main post, I use dynamic DNS services such as freemyip.com to update it with the IP. My virtual host is the free dynamic DNS domain. It works fine with other ADSL modem such as Huawei HG531 V1. Also as I regarded in the firmware Page TD-8810A_V4_091210 . They mentioned about this bug but it seems has no fix.
    *********************
    Best Regards,
    Said Bakr.

  4. #4
    I have fixed this issue, partially, by removing NAT -> Virtual Servers and creating DMZ Host to the my server's machine IP, i.e 192.168.1.10. Now all virtual hosts are accessible from the Internet, but it does not accessible from the LAN!
    Last edited by saidbakr; 07-17-2017 at 16:19.
    *********************
    Best Regards,
    Said Bakr.

  5. #5
    If you still have troubles, it's suggested to contact TP-link email support..

  6. #6
    Quote Originally Posted by vieldcs View Post
    If you still have troubles, it's suggested to contact TP-link email support..
    Unfortunately, I don't think that they will respond to the email, if they would not follow there forums! Additionally, I had tried to contact them before about other suggestion with no any response. Also, I have posted on their distributor's Facebook page in Egypt and they have made one call to me without any net result.

    I think that it is pretty clear that it is a bug in the Firmware and the only solution is to fix it by new Firmware release. However, TD-8810 is very old product and they may not do that for it.
    *********************
    Best Regards,
    Said Bakr.


 

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts

Copyright 1996-2017 TP-LINK Technologies Co., Ltd. All rights reserved.