Welcome to TP-LINK Tech Support Forum
+ Reply to Thread
Results 1 to 10 of 10
  1. #1

    Angry XBOX One "Teredo Address not obtained" error on Archer VR2600

    Model :

    Hardware Version :

    Firmware Version :

    ISP : [/COLOR]

    Hi,

    I replaced a standard Sky Router (for Sky Fibre) with a TP Link VR2600. Everything works fine, but the XBOX lost its multi-player and VOIP capabilities, which require IPV6 tunneling using the teredo protocol.
    I have enabled uPNP on the router, and some services seem to use it, but the XBOX does not seem to be able to deal with it.

    I have the latest firmware installed.

    Any idea what I can do to fix this (besides throwing the Archer VR2600 in the bin and re-installing the Sky Box)?

    Thanks for any help.

    Cheers

    Sven Erik
    Last edited by Anton L.Z.; 07-25-2017 at 08:33.

  2. #2
    Hi Sven,
    What ports do you have on UPNP list? Did you check the issue with XBOX support? You can check with them to see if the UPNP opened all the ports you need.
    You may have a try with DMZ for your XBOX.

  3. #3
    Hi Anton,

    XBOX support means Microsoft support, i.e. useless. "Have you switched it off and on again?"
    When I switch the XBOX on, I can see the required UPNP ports being assigned, but the XBOX does not seem to get through. No extra firewall rules set up, and even adding some exceptions to the general firewall setup does not seem to help.

    I do not know the Teredo protocol at all, would something like Wireshark help to determine what is going on on the network.

    At a loss here. For once, the Sky Box seems to have the upper hand.

  4. #4
    try port forwarding for Xbox or DMZ.
    For the ipv6, set it up as the sky router.

  5. #5
    I have had the same issue with my vr2600v and it took me ages to find a workaround for the upnp/NAT issues.

    What works for me is to set a bandwidth cap in your router settings. It can be as high as your max internet speed, so it doesn´t negatively impact anything.

    For some reason this forces port forwarding rules and upnp to work consistently.
    Someone posted this workaround for a different issue and I tried it out of desperation. With success!

    Here is the forum post where I found the workaround:
    http://forum.tp-link.com/showthread....675#post195675

    I hope this helps others with the same problem.

  6. #6
    Ervelos, you are a certified genius.

    Your fix worked perfectly, thank you very much.

    For future reference, a TP Link VR2600 will work with the Teredo protocol for IPV6 addresses required by the XBOX for online chat if the bandwidth limits in VR2600 are enabled, even if they are set to the allowed maximum value.
    Very odd bug, hopefully fixed in a future firmware upgrade.

    Thanks all for your input and help

  7. #7
    Junior Member greeny1992 is on a distinguished road
    Join Date
    Jul 2017
    Posts
    1
    This seems to be the thread ive been for.
    Had problems for the last month or so with my xbox since getting an archer vr2600
    im getting constant nat problems i.e NAT: Unavailable NAT: Strict was fine before i put this router in.
    On the settings, do i enable bandwidth control? and then what do i put in the box's? amateur with this sort of stuff

    Thanks!

  8. #8
    Quote Originally Posted by greeny1992 View Post
    This seems to be the thread ive been for.
    Had problems for the last month or so with my xbox since getting an archer vr2600
    im getting constant nat problems i.e NAT: Unavailable NAT: Strict was fine before i put this router in.
    On the settings, do i enable bandwidth control? and then what do i put in the box's? amateur with this sort of stuff

    Thanks!
    You enable the badnwidth control and into the fields you put values higher than your actual internet connection speed. For example in my case:

    Current Upstream Rate: 36178 Kbps

    Current Downstream Rate: 96490 Kbps


    Values I put in are

    Total Upstream Bandwidth: 40000 kbps

    Total Downstream Bandwidth: 100000 kbps

    You don´t need to add any rules. Just save the changes and make sure upnp is enabled under NAT forwarding as well. That is all there is to do.

  9. #9
    Lucky you Ervelos, to have bandwidth like this :-)

    My firmware didn't allow me to enter values higher than the current rates, so in my case I had to set the limits to reported values.

  10. #10
    Quote Originally Posted by seknop View Post
    Lucky you Ervelos, to have bandwidth like this :-)

    My firmware didn't allow me to enter values higher than the current rates, so in my case I had to set the limits to reported values.
    Thinking about it, I am not sure I am able to set higher values either. Maybe at the time my synced speed was slightly above the values I set.


 

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts

Copyright © 1996-2017 TP-LINK Technologies Co., Ltd. All rights reserved.