Welcome to TP-LINK Tech Support Forum
+ Reply to Thread
Results 1 to 7 of 7
  1. #1

    TP Link Firmware Recovery Utility - No LEDs lit? Try this.

    Model :

    Hardware Version :

    Firmware Version :

    ISP : [/COLOR]

    TP Link seem unwilling to upload this themselves for some internal reason.

    If your firmware update fails and your TP-LINK powerline adaptor is "dead" after a powercycle, this should rescue it.


  2. #2
    Thanks for sharing!

  3. #3

    Can you reup the PLC Recovery Tool i get message wpcap.dll is missing


  4. #4
    The software hasn't changed. Works here.

  5. #5
    Junior Member LastReaction is on a distinguished road
    Join Date
    Dec 2017
    I tried to use the software to recover my powerline adapter, but when I type in the correct PLC MAC Address using the format the software tells you to use, and browse for the correct firmware files, when I press the Scan button it says "No device to recover!" Am I doing something wrong? I have WinPcap installed, as well as the latest TP-Link PLC Utility. I also ran the PLC Recover Tool in Administrator Mode. I'm using the software on Windows 10.

    Are there any additional steps I need to take besides the ones I listed above? Any help would be appreciated.

  6. #6
    If I recall correctly you should not need to type in the MAC address it should scan and find it. Is is bricked after an attempted firmware update?You are directly connected via Ethernet cable? You get a link light on PC? What model and version?

  7. #7
    Junior Member jamieandrew is on a distinguished road
    Join Date
    Jan 2018

    Cool Solved plc recovery tool

    if you cant get your powerline to be found within the tool as i couldnt when i installed the incorrect frimware for my powerline , you must install the incorrect firmware again and power the adapter off during the update as this will brick your device and you will be able to get back to the correct firmware through this tool, the problem i was having was my device still worked on the incorrect firmware but would not allow me to update to the correct one using the above mehtod you can install the correct firmware


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts

Copyright 1996-2018 TP-LINK Technologies Co., Ltd. All rights reserved.