Welcome to TP-LINK Tech Support Forum
+ Reply to Thread
Results 1 to 3 of 3
  1. #1
    Junior Member vjkdigital is on a distinguished road
    Join Date
    Jun 2017

    Lightbulb Archer C9 won't connect with Sonoff TH WiFi switches?

    Model :

    Hardware Version :

    Firmware Version :

    ISP : [/COLOR]

    HiI've just replaced my router with a tp-link Archer C9. However I can't get any of my 3 Sonoff TH units to connect with it. I have tried various security settings including no security and no password. I've made sure the mobile I'm using to add the sonoff is connected to the 2.4 band and not the 5ghz band. I have also dropped the bandwidth from 40mhz to 20mhz but they still won't connect. My other 10 devices seem to connect fine to 2.4ghz including cameras laptops and TV boxes. I've also tried different security types and made sure the firmware is the latest. I think the clue is that the router supports up to 600mbps not 300mbps like most routers. Even though I've dropped the bandwidth to 20mhz my phone still says it's connected at 192mbps. My old modem used to show 130mbps. I think this is the problem. Would anyone have any suggestions as to how to get these three units to connect please

  2. #2
    i think you can ask sonoff TH unit company what setting can change on the router to make it connect. As your other devices can connect fine.

  3. #3

    Similar problems with SonOff switches

    I've also had problems getting SOME Sonoff switches to pair with my Archer C9 router. Specifically the combined WiFi+RF versions. You can read in detail here http://support.iteadstudio.com/support/tickets/65964 If you are unable to access this then here is the text-

    1. I received FOUR Sonoff (single channel) switches today direct from China. Two of them were the BASIC version (Wifi only) and these paired easily (and updated firmware) with my wifi. Unfortunately the two Wifi+RF units would not connect (LEDs showing setup mode) although they do work with an RF dongle. Sadly this is the second batch of Sonoff switches I have received and BOTH orders have had a 50% failure rate! All units were setup using the same network. The two Wifi+RF units have tags with DA4154A [28-12-F03] . I'll add the following information- Model Number ITA-GZ1-GLSerial Numbers 100029423d & 1000294487

    Tried one of them connecting via temporary Hot-spot on one of my mobile phones-- that worked BUT of course I can't use that all the time.as tethering is not permitted on my phone contract.

    Tried setting my TP-Link router to use DNS and -- no change.


    I have spent a lot of time diagnosing this problem - it seems that there is something "strange" about Firmware 1.6.0 on SOME of the Wifi+RF switches! (But no problem with BASIC switches)

    I have one WiFi+RF unit that works perfectly!
    All my WiFi ONLY (basic) units work perfectly!

    In the recent delivery TWO Wifi+RF units work on RF however
    1.Work on WiFi using old Netgear router (default settings) plus work with tethered phone via 4G data.

    2. NEITHER switch (100029423d or 1000294487) will connect to my normal router (TP-Link AC 1900 Archer C9)

    I have tried as you suggested--
    1. Assigning fixed IP addresses to each MAC address on C9 Router (obtained when connecting by tethered phone)
    2.Manually changing DNS addresses to and
    3.Increasing size of address pool on C9 Router

    NONE of the above made any difference even after initially registering each switch with OLD (Non ac) router.

    In each case (when Archer C9 is router) the faulty switch LED blinks slowly showing NO CONNECTION and any attempt to setup using EWELink fails!

    As ONE of these WiFi+RF switches works fine with same 1.6.0 firmware and any router/tether then it is obvious that you have made some change in the hardware that is causing the problem. I am happy to conduct any tests or provide any further information. Other have reported the same problem so it is important for you to sort this out (as Google have had to do recently with their Google Home devices which were "flooding" IP addresses)
    I look forward to your progress in this matter!

    So far no serious response from SonOff-- just the usual "it must be something wrong with your router" which is rubbish as on of the Wifi+RF switches does work as do all my numerous other Wifi devices!


Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts

Copyright 1996-2018 TP-LINK Technologies Co., Ltd. All rights reserved.