Welcome to TP-LINK Tech Support Forum
+ Reply to Thread
Results 1 to 4 of 4
  1. #1

    TL WPS510U print server set up

    Model :

    Hardware Version :

    Firmware Version :

    ISP : [/COLOR]

    I have recently purchased the above print server & am having major problems setting it up.Using the supplied setup disc, my computer (windows XP) was unable to detect the print server.Using information from the TP Link website I followed instructions for a manual set up of the server, this to proved fruitless.I then read it was possible to use an Ipad to effect the setup, following the website instructions I was at last able to access the print server login. On entering the default username & password, the login appeared to work & I was finally expecting to see the server setup page but alas all just a blank screen. Can anybody point me in the right direction to get this device working, I can see it as a wifi device on my Ipad/s & windows 10 laptopThanks in anticipation RonJA

  2. #2
    You may try a hard reset on the print server, then do the configuration again with the iPad. Windows 10 cannot connect to the wifi of the print server, so you cannot do the setup on Windows 10, but you can use Windows 10 to work with the print server after the configuration.
    If you still have a problem to set it up, it's suggested to call TP-Link support.

  3. #3

    Logs in & then loses connection

    Thanks for the reply.I have tried the hard reset several times to no good effect. As previously mentioned I can get to the login, using username admin & password 0000 , the Ipad begins to log onto the print server but the loses connection. This is where in my opinion the problem lies.I have had several conversations with TP-link support & had to point out on the FAQ's it says log in username is admin & password admin. This is at odds with the printed instructions supplied with the device, support finally conceded the printed instructions were correct but FAQ's remain unchanged. Tried several of their suggestions but still unable to get passed log in.Any further suggestions greatfully received, I would dearly like to get this device working.

  4. #4
    try another web browser on the ipad? old version is using 0000 as login password but new version change to admin.
    or try a mac to setup?


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts

Copyright 1996-2018 TP-LINK Technologies Co., Ltd. All rights reserved.