Welcome to TP-LINK Tech Support Forum
+ Reply to Thread
Results 1 to 2 of 2
  1. #1
    Junior Member
    Join Date
    May 2017
    Posts
    1

    Using Printers and Wired Devices with Deco M5

    Model :

    Hardware Version :

    Firmware Version :

    ISP : [/COLOR]

    Hi all,

    I just installed the Deco M5 Whole-Home Wi-Fi system in my apartment (3-pack) and most everything is working perfectly. However, I'm running into an issue working with both wired and wireless devices which is also impacting my wireless network printer in particular. This is likely due to my home network setup, and I'd love to get some advice on how to resolve this issue.

    I have AT&T Fiber as my ISP, which means I was previously stuck with using their combo modem/router gateway device. To make Deco work with the gateway, I had to turn off the wireless feature on the gateway (effectively putting it into bridge mode, I assume). I then plugged an ethernet cable from one of the free LAN ports on the gateway to one of the two LAN ports on the primary Deco. The Deco is now presumably managing most of the network traffic. I also plugged in a network switch to the other free LAN port on the Deco so that I could add more wired devices to my network including an Apple TV. I also added a wireless printer to the Deco wireless network, to which my wireless laptops were able to print successfully. This wireless printer does have an ethernet port for hardwiring to a switch or a free port on the Deco unit, but I was able to set it up wirelessly.

    However, I have a separate computer in my home office which is having issues connecting to the printer when on a wired connection. While I do have another Deco in this office, I also have an ethernet port on my wall which is live, and enables me to plug in my wired computer. However, that LAN connection seems to be managed by my AT&T gateway, and not by the Deco network. This wired computer will not recognize or print to the network printer UNLESS I disable the wired connection and hop on the Deco wireless network. Normally, I don't mind using Wi-Fi, but this primary computer does need a wired connection for work purposes. Assuming I'm running into a Double NAT issue because of the separate connections created by the gateway device and the Deco network, does anyone have any ideas on how I can get my wired computer to talk to the wireless printer since they are apparently on two separate networks? Thanks!

  2. #2
    Junior Member
    Join Date
    May 2017
    Posts
    1
    I believe you are correct in that your wired computer is managed by the AT&T gateway. I am assuming the AT&T has 4 LAN ports, one port has a cable plugged into the primary Deco unit, and another port has a cable plugged into a wall Ethernet jack that goes to the wired computer.

    If so, the issue you are running into is that the computer wired connection needs to be plugged in after the first Deco unit, as devices plugged directly into the ATT gateway cant see devices plugged into the Deco units and vice versa.

    To resolve your issue, you will need to move all Ethernet cables plugged into the LAN ports of the AT&T gateway into free ports on the switch plugged into the Deco (the switch your Apple TV is plugged into). If your switch doesn't have anymore ports you will need to buy a switch with more ports.

    You're setup should be Modem/AT&T Gateway---Deco---Switch---All wired devices. And let the printer magic flow!


 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts

Copyright 1996-2017 TP-LINK Technologies Co., Ltd. All rights reserved.