Welcome to TP-LINK Tech Support Forum
+ Reply to Thread
Results 1 to 6 of 6
  1. #1

    Invalid user name - EAP

    Model :

    Hardware Version :

    Firmware Version :

    ISP : [/COLOR]

    I installed eap controller 2.4.7 and create a username and password. Into login page, i can access normally, but using http post request like https://127.0.0.1:8043/login (by postman) with same credentials, is returned: "Invalid user name.".


    Can anyone help me? How is that possible?

    EAP Controller: http://www.tp-link.com/en/download/E...oller_Software

    What i tried: http://www.tp-link.com/us/faq-928.html


    Below, the evidences:

    Name:  tela login.png
Views: 0
Size:  22.1 KB

    Name:  tela adm.png
Views: 0
Size:  55.8 KB

    Name:  falha.png
Views: 0
Size:  48.3 KB

  2. #2
    Members R1D2 is on a distinguished road
    Join Date
    Dec 2015
    Posts
    1,008
    Try it with content-type application/x-www-form-urlencoded instead of raw. It works for me using curl with this content type.

  3. #3
    Thanks R1D2, now I got success to log in.

    But I have another problem, in the next step 8 of http://www.tp-link.com/us/faq-928.html, I tried make a "fake" request, only to get a JSON and test before build my app. So, all my requests generated a HTTP Error 400:

    Name:  error 400.jpg
Views: 0
Size:  82.0 KB

  4. #4
    Members R1D2 is on a distinguished road
    Join Date
    Dec 2015
    Posts
    1,008
    I'm not sure, but probably now you have to use raw mode. The difference is that with the login request you simulate filling in a form and submitting it, while the request for authentication might be processed differently. Try raw mode and set Content-type and Content-length header appropriately. Just a guess.

    Unfortunately TP-Link's documentation for Business Class devices is lacking details needed for proper integration in customized systems. While I understand the (intentional) lack of technical details in the documentation for SOHO equipment to keep the average user happy, I think for SMB equipment TP-Link should make a little more in-depth documentation available, at least to system integrators such as you and me.

  5. #5
    Nice R1D2 , you were right! It worked! I changed to raw and text/plain and i got the json. You are correct, this docs are not enought to build an app, we need more information and examples. But now i can continue and do more tests.


    Thank you very much!

  6. #6
    Members R1D2 is on a distinguished road
    Join Date
    Dec 2015
    Posts
    1,008
    Quote Originally Posted by gjunior022 View Post
    Thank you very much!
    Glad it worked! So it saves me time for a test on my own, thank you for the feedback!


 

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts

Copyright 1996-2017 TP-LINK Technologies Co., Ltd. All rights reserved.