Welcome to TP-LINK Tech Support Forum
+ Reply to Thread
Page 1 of 2 1 2 LastLast
Results 1 to 15 of 19
  1. #1

    I NEED cpe210 DUMP

    Model :

    Hardware Version :

    Firmware Version :

    ISP : [/COLOR]

    im trying to fix my cpe210 from moving from openwrt and i need dump to fix it, can any body help.
    ps. the downloadable fw is missing bootloader
    Thank you

  2. #2
    Quote Originally Posted by mixawy0 View Post
    ps. the downloadable fw is missing bootloader
    No. The boot loader of any device should never ever be touched. That's BTW the big mistake the OpenWRT firmware did in first place!

    I have attached the Uboot/SafeLoader of a CPE210 v1.0 to this post. Use it on your own risk! It has to be flashed into /dev/mtd0.
    Size is 131072 bytes after unzipping, MD5 is: (uboot-cpe210) = 03af561034b6faf8d93adda8eed591dd

    Code:
    dev:  size     erasesize  name
    mtd0: 00020000 00010000   "u-boot"
    Attached Files
    Last edited by R1D2; 05-10-2017 at 18:44.

  3. #3
    Yes that's right, can you help.

  4. #4
    The only reason i flashed openwrt is because the original fw doesn't work with my eduroam in my university.

  5. #5
    Quote Originally Posted by mixawy0 View Post
    The only reason i flashed openwrt is because the original fw doesn't work with my eduroam in my university.
    There was a beta version for PharOS available for RADIUS authorization, which should work with eduroam. Seems it has been integrated in the official firmware since PharOS v1.3.2.

    See http://forum.tp-link.com/showthread....-with-MikroTik.
    Last edited by R1D2; 05-10-2017 at 19:00.

  6. #6
    the boot loader didnt work i get the same output as the old bootloader, i have v1.1 dose it make any difference, i used your image and flashed it on the spi flash using usb programmer, i get this

    2J▒[1;1HTP-LI▒K ▒afeLoader (Build▒ti▒e: Jan 14 2015 -▒11▒01:05)
    CPU: 56▒MH▒ A▒B: 225MHz DDR▒ 6▒MB▒
    Press C▒RL▒B to enter SafeL▒ad▒r: 1e▒forming LED chec▒.. PA▒S
    ▒lash Manufacture▒: ▒nknown(0xc8))1
    Fl▒sh▒Device ID: Unkno▒n(▒x4017)
    Data fla▒h ▒nit failed.
    open user-co▒fi▒ failed.
    open u▒er▒config failed.


    enet0 p▒rt▒ up
    TFTP ▒er▒er address is▒19▒.168.0.100; our ▒dd▒ess is 192.168.0▒25▒
    TFTP ▒er▒er address is 19▒.1▒8.0.100; our ▒dd▒ess is 192.168.0▒25▒
    Get filename '▒ecovery.bin'.
    #######▒▒########▒▒######################▒#####▒#▒ ##▒###▒########
    ###########▒###▒###▒▒######▒####
    ▒By▒es transferred =▒49▒6747, 621 Kby▒es▒secs▒0x▒
    ▒nc▒rrect File.oa▒ed outside of th▒ r▒served load a▒ea▒ memory corrupti▒n ▒ay ocWri▒ti▒g error.
    ▒nput▒Pa▒sword:
    ?25lopen user▒co▒fig failed.
    ope▒ u▒er-config failed▒

    Thank you for your help

  7. #7
    Maybe it's best to ask someone who has a v1.1 to send you a dump of all partitions including the device config and user config sections. Sorry, I don't have a v1.1 version of CPE210 at hand, mine are all v1.0. Probably RTouris can help?

  8. #8
    I'm afraid I'm purely on CEP510s..., sorry :/

  9. #9
    i have successfully fixed my router , still with bad recovery, but what i have done is reading my old dumb and write the os at the right address which is 40000 and that was it for me, so i guess if anybody want to restore pharos should do the same, i can upload my dump if it can help to any body
    Thank you for your help.

    edit: i restored it to openwrt i couldn't flash pharos
    Last edited by mixawy0; 05-10-2017 at 21:45.

  10. #10
    i would be gladful if anyone uploads a pharos flash dump, cpe510 is the same as cpe210

  11. #11
    Quote Originally Posted by mixawy0 View Post
    i would be gladful if anyone uploads a pharos flash dump, cpe510 is the same as cpe210
    Only firmware is the same (and probably Uboot), but not the device config & ART partitions. You should try to get a dump of those partitions for a CPE 210 v1.1.

  12. #12

  13. #13
    well what did is just remove the spi flash from the ap the image of the chip is in the other thread , read and save the current image on the chip, then with a hex editor copy a openwrt sysupgrade fw to address 40000 in the image that i red, save the new file and flash it
    but i didn't have any luck installing pharos fw , maybe because the is a signature partition that is missing.
    you can also buy a cheaper one XTW100 mini programmer USB

  14. #14
    Hi, well I cannot really imagine what to do with the device after I get it. You say "just remove the spi flash from the ap". How do you remove it? Solder it out, flash it and then solder it back in place? I would try that, if that is what you meant. Let me pick your brain a little more - how do you know which USB Programmer can do what you want? I can order any one, but both that you suggested I can only find from China. It takes an item 3+ weeks to arrive from China to Spain. If I could order some programmer available on Amazon.es premium, it will all happen much faster. The ones you suggest are not available, however, what I can find that seems similar are:
    https://www.amazon.es/WINGONEER-velo...ywords=ezp2013
    https://www.amazon.es/WINGONEER-EEPR...rogramador+usb
    However, I cannot figure out whether these will do what I need.
    And also can you tell me, if these clamps are any good for me, as it seems they are made especially for reprogramming without "removal"?
    https://www.amazon.es/WINGONEER-vers...7V9WPGR7A7D7TG
    What software do you use to read and write the dumps?

  15. #15
    You are right, you can get the cable to flash the spi without desolder it, the software comes with the programmer, you can edit the dump in a hex editor then flash itAny progrmmer would work that you mentioned. Ask me any thing, happy to help.


 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts

Copyright 1996-2017 TP-LINK Technologies Co., Ltd. All rights reserved.