Welcome to TP-LINK Tech Support Forum
+ Reply to Thread
Results 1 to 7 of 7
  1. #1

    Unable to forward port 80 from WAN to a virtual server

    Model :

    Hardware Version :

    Firmware Version :

    ISP : [/COLOR]

    I have a TD-W8960N running in NAT mode. I want to forward port 80 (and others) to a server inside my network.

    When I add port 80 on the external side I get a message saying it is already in use and the external port is changed to 8080.

    When I access the external IP of my ADSL connection it shows the TD-W8960N admin page.

    How can I configure the router to NOT expose the admin web interface AND use the port for my own web server?

  2. #2
    Banned jimasek is on a distinguished road
    Join Date
    Jan 2013
    Posts
    2,567
    Hardware version of your W8960N?

  3. #3
    V7 and running the latest firmware downloaded from tp-link

  4. #4
    Can you tried to forward other port like 9000? Port 80 is used by the Web UI.

  5. #5
    I have several other ports forwarded for email, https, ssh etc. I run a web server hence the need for port 80.

    Also under no circumstances do I want the admin interface availabe to the internet. I disconnected this router as soon as I found out it was. If this cannot be disabled I will be returning it as a defective product.

  6. #6
    If you do not want the admin interface available to the internet. You can go to Mangement > Access control> Remote Access then uncheck the option of web.

  7. #7
    Junior Member agrov8 is on a distinguished road
    Join Date
    Jul 2017
    Posts
    1

    inconsistent settings security bug

    Ref: TD-W8960N V7,
    1.0.9 Build 160614 Rel.41323, also applies to previous (factory version)

    So, I want to host port 80 web service, but it appears I cannot even after a firmware update, because the management interface "owns" port 80 on all interfaces and wont move to any other port come hell or highwater.

    Also, The management port 80 interface will become visible to the internet at large (*very bad*) if you ..

    1. turn on virtual servers for *any* port under Advanced -> NAT -> virtual servers, regardless of the setting in Management -> Access Control -> remote access.

    This is just poor design.


 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts

Copyright 1996-2017 TP-LINK Technologies Co., Ltd. All rights reserved.