Welcome to TP-LINK Tech Support Forum
+ Reply to Thread
Results 1 to 4 of 4
  1. #1

    Macbook can't connect to RE350

    Model :

    Hardware Version :

    Firmware Version :

    ISP : [/COLOR]

    Hello,

    I have an Wi-Fi Range Extender RE350. I am having trouble connecting 1 of my Macbook to the RE350. It keeps throwing error "Invalid Password" despite multiple retries with the correct password (i'm very sure of that). Anyone facing the same problem?

    Thanks,
    JS

  2. #2
    Have you checked different SSID on the repeater? Then your computer have asked about password?
    I know, my English isn't perfect but I'm trying

  3. #3
    Junior Member
    Join Date
    May 2017
    Posts
    1
    I have the same problem. I went through the setup process multiple times with the same result. The unit does not get an ip addressed assigned I believe due to the fact that the password isn't recognized for it asks for the correct password to be provided although the correct password was given initially. ???

  4. #4
    Junior Member
    Join Date
    May 2017
    Posts
    1
    I'm encountering the exact same issue on my Macbook Pro and Macbook Air. I've tried using the main router's SSID and also assigning a new SSID to the RE305's networks and neither works.

    My iPhone connects to the RE305's extended network without an issue.

    My main router is an Asus RT-AC68R.


 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts

Copyright 1996-2017 TP-LINK Technologies Co., Ltd. All rights reserved.