Welcome to TP-LINK Tech Support Forum
+ Reply to Thread
Results 1 to 8 of 8
  1. #1

    Macbook can't connect to RE350

    Model :

    Hardware Version :

    Firmware Version :

    ISP : [/COLOR]

    Hello,

    I have an Wi-Fi Range Extender RE350. I am having trouble connecting 1 of my Macbook to the RE350. It keeps throwing error "Invalid Password" despite multiple retries with the correct password (i'm very sure of that). Anyone facing the same problem?

    Thanks,
    JS

  2. #2
    Banned jimasek is on a distinguished road
    Join Date
    Jan 2013
    Posts
    2,565
    Have you checked different SSID on the repeater? Then your computer have asked about password?

  3. #3
    Junior Member AL D is on a distinguished road
    Join Date
    May 2017
    Posts
    1
    I have the same problem. I went through the setup process multiple times with the same result. The unit does not get an ip addressed assigned I believe due to the fact that the password isn't recognized for it asks for the correct password to be provided although the correct password was given initially. ???

  4. #4
    Junior Member spence3eb is on a distinguished road
    Join Date
    May 2017
    Posts
    1
    I'm encountering the exact same issue on my Macbook Pro and Macbook Air. I've tried using the main router's SSID and also assigning a new SSID to the RE305's networks and neither works.

    My iPhone connects to the RE305's extended network without an issue.

    My main router is an Asus RT-AC68R.

  5. #5
    Junior Member Keitaroou is on a distinguished road
    Join Date
    May 2017
    Posts
    1

    Same issue

    Had anyone found a solution to this problem yet? I am having the same issue as well. With the extender present my MacBook oddly cannot connect. With it turned off my MacBook connects fine.All my other devices iPad iPhone thinkpad have no problems connecting with the extender present. This is really frustrating, might just return it for something better if I can figure this out soon.

  6. #6
    Junior Member jeremytm is on a distinguished road
    Join Date
    Jun 2017
    Posts
    1
    I have had issues connecting my Macbook Pro to an Asus RT-AC5300 on the 2.4ghz band if I'm too close to the router.
    Solution: move at least a couple metres away from the router.

    I also had issues connecting to TP-Link RE350 on the 2.4ghz band, or it would connect to repeater but have no internet connectivity.
    Solution: Turn off DHCP server on the repeater. Go to the web control panel for the RE350 > Network > DHCP Server Settings > DHCP Server: Set to OFF (Click save)

    Also try: Switch the channel bandwidth on the main router, to only use 20mhz, as shown in this guy's video: https://www.youtube.com/watch?v=mNM2gq97vDs

  7. #7

    Same issue with TL-WA850RE

    I can access it with every other device except my Macbook. My router is an ASUS RTN12-HP and my repeater is TL-WA850RE.

    Perhaps this is an issue with Asus Routers? Can anyone confirm?

    How do you solve this?

  8. #8

    Yes, same issue with TL-WA850RE

    I cannot connect to this device from my Macbook (which is running El Capitan) - it simply doesn't work - 'invalid password'. The Macbook connects to the router itself (a TP-Link VR400) just fine, and other devices in the household (iPhone, iPad, Android tablet, Android phone, Windows 10 laptop) can all connect to the repeater so I don't think it's me.

    TP-Link, are you listening? It would be nice to have a fix for this.


 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts

Copyright 1996-2017 TP-LINK Technologies Co., Ltd. All rights reserved.