Welcome to TP-LINK Tech Support Forum
+ Reply to Thread
Results 1 to 14 of 14
  1. #1

    Question TL-R480T+ "Online detection failed" for ever

    Model :

    Hardware Version :

    Firmware Version :

    ISP : [/COLOR]

    I was trying to ask this to tech support, but they just closed the chat after reading the question - my first experience with TP-Link tech support!

    I own this TL-480T+ recently and was trying to use it between two internet connections - WAN1 as primary and WAN2 as backup. WAN1 has a daily data cap, and after that it disconnects from internet - basically ping failure will happen (to 8.8.8.8, which I manually configured). Then it is expected to switch to backup. This works as expected and WAN1 will be marked as "Online detection failed" - which is perfectly true.

    The issue is at midnight, once the data cap is reset, ISP connected to WAN1 will be again active. The test IP address 8.8.8.8 will ping again. However, the router won't honer that and stays forever as "Online detection failed". I need to go, disconnect WAN2 cable to force it back to WAN1. This is not what is expected.

    Do anyone else have this problem? I do manual online detection, only using ping to 8.8.8.8. DNS lookup based online detection is disabled on purpose. The ISP CPE has captive portal, which spoof any DNS request (while disconnected from internet) and respond back with its own IP - which will trick the router unless I disable it.

    I could have lived with this issue if there was a shell based or API based facility to disable/enable selected ports. I should have configured a script post midnight to disable backup WAN for few seconds to wake up primary and then enable backup - however I don't see any way to disable/enable ports except physically disconnecting the cable. Is there any such facility which I am missing?

    Regards,

    Sreejith
    Attached Images  

  2. #2
    is that waste of money?

  3. #3
    Quote Originally Posted by w20grippy View Post
    is that waste of money?
    After using this for last few weeks, I can confirm it is almost a waste of money. As you see above, tech support is useless and helpless. I believe they close chats so rudely because they don't have any answer or solution. By not talking to me, I take it as they acknowledge that this is a known issue and they don't have a solution. They must be feeling ashamed to face customers.

    Net result is, it works when it works, and every day I need to do some physical intervention with the router to activate fail overs. Many times it fails online detection - even if respective test ip addresses are reachable (and still pingable through the diagnosis page of same device).

    No API to deal the situation automatically except rebooting the whole router - which is the last resort for me. May be I will end up there.

    My current situation is - I always keep one WAN cable disconnected. Yes, I do the fail overs manually now - which defeats the whole purpose of buying this router - thus I can proudly declare that it is a waste of money.

    So, the best is to stay away from this. If you really want to give it a try, go for the cheaper TL-R470 model to apply stop loss on your attempt.

    If any of TP-Link guys reading this - I am still open to work with you as a gunny pig to help/test your new firmwares. I am sure it is a good hardware and these issues are just the software side. If you are keen in improving your product and thus survive in the market, take this seriously.

  4. #4
    Hey dude, What't your Online detection setting like? For Auto Mode, it will ping to the gateway of itself, which means if you have a device before the R480T+, and it will always show online.

  5. #5
    Quote Originally Posted by Panda View Post
    Hey dude, What't your Online detection setting like? For Auto Mode, it will ping to the gateway of itself, which means if you have a device before the R480T+, and it will always show online.
    Hi, thanks for looking into this post - if you re-read, as I specified,
    I do manual online detection, only using ping to 8.8.8.8. DNS lookup based online detection is disabled on purpose...
    Therefore, issue is not due to the automatic online detection.

  6. #6

    Lightbulb A solution for wrong "Online Detection" use ?

    Hi,

    I've got exactly the same issue with my 480t+ !!!

    It's because of the include firmware test process which can not use the right value... They will have to use « Port Status » var and not « System Status » var when the user activated the « Online detection » with « Link Backup » .

    If you're looking at var in your TP LINK console you will be able to see... when adsl signal input is down for a modem (ex : WAN 1) Name:  Schéma Global Réseau - Problème avec Failover sur perte signal ADSL.jpg
Views: 0
Size:  140.1 KB:

    Status / System Status
    WAN 1 / Connection status = Link Up / => With the ping test it should have to be down !!!
    WAN 2 /
    Connection status = Link Up / => Normal because of the "link backup" option

    Transmission / Load Balancing / Online Dectection
    WAN 1 / Port Status = Offline / => Normal because of the ping test NOK
    WAN 2 / Port Status = Online / => Normal because the second modem is up ;-)

    We should be able to read this :

    IF WAN 1 / Port Status = Offline => WAN 1 / Connection status = Link Down

    NB :
    Even if the link is physically active, the WAN is unusable because no adsl signal !!! So "Link Down" and full switch to an other WAN with "Link Backup" option otherwise, dns issue few minutes after the adsl loss from modem/router input...

    Please, have a try with your hardware ;-)

    So, TP LINK developpers.... juste need to change a simple var in the "system status" test... use the "Port Status" if test ping activated

    PS : Sorry for my english ;-(
    Last edited by Seblard; 12-26-2017 at 21:21.

  7. #7
    hello, I have the same problem with TL-ER5120.you see my post here : http://forum.tp-link.com/showthread....-ER5120-V3have you a solution ?

  8. #8
    Hi,

    The only way I had found to make my TL-R480T+ work (a kind of bad link backup) was with this params... thanks a lot Murphy from Tp-Link support : support.smb@tp-link.com

    Network => Screen copy (wan1 & wan2)
    No bandwith control
    No session limit
    Basic Settings => Screen copy
    No Link Backup
    Online Detection => Screen copy (wan1 & wan2)

    Name:  WAN1.JPG
Views: 0
Size:  49.6 KBName:  WAN2.JPG
Views: 0
Size:  50.5 KB
    Name:  Basic Settings.JPG
Views: 0
Size:  26.4 KB
    Name:  Online Detection WAN1.JPG
Views: 0
Size:  38.4 KBName:  Online Detection WAN2.JPG
Views: 0
Size:  37.5 KB

    Hope it will help you...

    NB : WAN2 down / upstream bandwith are setting =100 because I want that WAN1 is priority ;-)
    Last edited by Seblard; 01-20-2018 at 10:18.

  9. #9
    «*NB : WAN2 down / upstream bandwith are setting =100 because I want that WAN1 is priority*» with load balancing, it’s a good idea !and it’s ok ?if wan1 is off, wan2 keep the connection.And if wan1 comes back, the router switch on wan1 ?

  10. #10
    If wan1 and wan2 are up load balancing is working. As soon as a wan is down, the other one keep the connexion working... but don't forget to disable "link backup" fonction and adapt each wan bandwith ;-) Just try it:-)
    Last edited by Seblard; 01-20-2018 at 20:26.

  11. #11
    "but don't forget to disable "link backup"
    Are you sure ?

    I would like to have link backup !!!

    Can you give me more explain please ?

  12. #12
    Jjacques68 I had given all my params with screen copy... If you want to be sure you just have to test it ;-) it's working as link backup ;-) Otherway you should contact TPLINK support...
    Last edited by Seblard; 01-21-2018 at 20:16.

  13. #13
    ok, I just set the same setting as you.I keep its for few days and I will check the result...I will say you if it’s ok...

  14. #14
    so.i’m sorry but it doesn’t work.and i think it’s because the ratio of load balancing.if bandwidth of WAN1 is to 20 000 kbs and WAN2 is to 100 kbs (too much in 4G), the ratio is 200:1.so it’s probably impossible to have a good connection on WAN2.there is a connection, but very very very slowly and hazardous.I do another tests with link backup, and clearly, the router is completely lost with the dns.when WAN1 is down, I can ping google with any problems. But impossible to go on the net.I try all the possibility with configuration of the DNS, anything works.But if I disconnect manually WAN1 it’s work.it’s boring, and i think this product is not good for link backup.


 

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts

Copyright © 1996-2018 TP-LINK Technologies Co., Ltd. All rights reserved.