Welcome to TP-LINK Tech Support Forum
+ Reply to Thread
Results 1 to 10 of 10
  1. #1

    HS105 Keep Falling off from network

    Model :

    Hardware Version :

    Firmware Version :

    ISP : [/COLOR]

    Hi I just got the new HS105 mini Smart plugs, I have a issue with them every 2-3 days they keep falling off the network. The light on it goes SOLID AMBER. So Can someone tell me if they have found a fix for it yet or not. Tp-Link needs to fix this I am on Hardware ver 1.0 and Firmware version 1.1.3

  2. #2
    I'm having the same issue. I have two units and have tried it on two different wireless networks now, using HT40 and HT20, forcing high and low channels, changing authentication etc. They both drop from the network after a few days and don't re-establish a connection until I get behind my desks and remove them and remove them from the socket, and then plug them back in. Very annoying and renders the devices pointless. I've done the firmware upgrade using the iotUpgradeTool and no change.

  3. #3
    Could it be your router? Has it always been a problem? What if you move one plug closer to the router as a test?
    Last edited by Cdbma; 04-30-2017 at 18:46.

  4. #4
    Next time they drop off perhaps try rebooting your router. I've found that works with my devices that have that same problem - most often an LB130 but occasionally an HS200 and LB110. A proactive reboot early each morning (my router has a reboot schedule function) eliminates most of the occurrences. Seems there's something funky in the TP Link firmware where they occasionally drop and don't try to reconnect on their own.

  5. #5
    Junior Member bwbmom is on a distinguished road
    Join Date
    Apr 2015

    Not dependable

    I have 4 plugs and constantly have to delete and re-add 1 or more 1-2 times a week. I know it's not the router or all would be disconnected. Just unplugging and replugging doesn't always work. The plugs work manually by pushing the button. But it won't connect for the app or for Alexa to control. They will show greyed in the app and Alexa says they are not responding. But 1-3 of the 4 will be fine. Most times I have to delete from the app and go through the complete set up again. Sometimes even then it will only show local not remote and says not in wifi range yet the plug 2 feet away will be fine. I'm fed up!

  6. #6
    For the router, it's not the wifi that drops, it's that the router runs out of resources trying to keep up with the non-standard udp/multicast the TP Link devices use. Your other devices can be just fine while only the TP Links suffer. Nothing to lose from trying a power cycle of the router vs the full setup of the TP Link, right?

    Don't get me wrong, this is something the TP Link folks should address, but it can help make the devices usable until they do.

    An aftermarket app might help. With mine all but one stays connected all day (and I know, 'cause my app monitors them constantly and logs outages). My problematic LB130 does still drops a few times a day (it's furthest from my router) which is much less often than before. And now it always comes back - I haven't had to reset for months.

    I'm also running the latest firmware using the tool mentioned above - this version hasn't been pushed out via the TP Link app for some reason.

  7. #7

    Falling Off Network (constantly)

    My Smart Plug Mini HS105s drop off the network daily. Here is what I did initially to install them.


    1. I downloaded and registered the Kasa App for iPhone.
    2. I set up the Smart Plug Minis per the directions, attaching them to my home router.
    3. All of them (4 in total) were viewable and controllable via the Kasa App.
    4. I then turned on the remote functionality.
    5. I turned off the Wi-Fi on my phone, using only the cellular network and was able to turn them off remotely


    1. I downloaded and registered the Kasa App for iPhone.
    2. I set up the Smart Plug Minis per the directions, attaching them to my home router.
    3. All of them (4 in total) were viewable and controllable via the Kasa App.
    4. I then turned on the remote functionality.
    5. I turned off the Wi-Fi on my phone, using only the cellular network and was able to turn them off remotely


    1. The next morning, at work, I decided to test the units from work the next day, using the same cellular network as before.
    2. None of the units showed up like they had the previous night.
    3. When I got home that night and reconnected to my wi-fi, they still didn't show up.
    4. None of the units had lights on them of any kind.
    5. I powered off my router, and powered it back on and they began flashing blue and reconnected.
    6. I was once again able to connect to them and remote control them.


    1. When I got up the next morning, I opened the Kasa App
    2. I noticed that none of the devices showed up.
    3. I rebooted the router again and after a minute or so, they began showing up and became controllable.
    4. When I arrived at work and tested them over the cellular network, they were no longer available
    5. After returning home, I once again rebooted the router and only one of the three became viewable/controllable

    I was tired after arriving home so didn't devote time to further testing. Tonight or possibly this weekend it is my plan to do the following:

    1. Assign IP addresses from my DHCP Pool directly to the MAC addresses of each of them.
    2. Review the Router Logs to see what time they disconnect after being rebooted.

    I'm thinking that perhaps this is an issue related to them being knocked off and reconnecting and being assigned a new IP address, and then experiencing conflicts occurring in the ARP tables on the router. I am a technical person and this is frustrating. I can only imagine what the average consumer would think.

    I would hate to have to take these back and replace them with idiot motor driven timers, but lighting control while I am away on vacation is a non-negotiable.
    Last edited by tannasgh; 09-22-2017 at 15:10.

  8. #8
    I may have solved the issue of them falling off and becoming unusable. I will give it a few days before I declare victory. Here is what I did.

    1. I wrote down the MAC addresses of each of the smart plugs.
    2. I created IP address assignments for them out of my DHCP Pool and mapped them to the MAC addresses.
    3. I reset each one with the 10 second button press method.
    4. I restarted my router.
    5. I used the KASA app to add them back to my router.
    6. I turned on the remote switch for each and assigned each an appropriate icon.

    As of this morning they are accessible from both home and via the remote. I am now moving on to testing the scheduling functionality of them and will continue to monitor their availability. If they do drop off I will review my router logs to find out what time it occurred and then see if there is a correlation between the time they were turned on and the time they were turned off.

  9. #9
    If they're not flashing amber I would think they're still connected to the network and it's the app that's struggling. You can confirm by trying to ping them, they will respond if they're active.

    If you have any kind of WAP, network extender, or even 2.4 + 5 GHz network and you connect the phone to the 5GHz side the app may have trouble finding them (it's a bug in their protocol implementation). You could check if it's that by forcing the phone/app on the same part of the network as the switches.

    Not sure about the cloud/remote issues, sounds like a bug, hopefully the TP Link folks here will know. If the switches are still connected to your wifi maybe try a logoff/logon or an app reset will find them in the cloud?

  10. #10

    I posted a reply earlier, but it doesn't seem that the moderator has released it yet. It seems that assigning IP Addresses from my DHCP pool to the MAC addresses of those devices has kept them from dropping off. My DHCP has a 24 hour refresh cycle on it. So far today, I am able to control them both from the LAN at the house and from the cellular network so it would seem they are functioning properly. I'm going to run with this change for a few days and see if it resolves the issue. If it does, I will return to post an update.


Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts

Copyright 1996-2017 TP-LINK Technologies Co., Ltd. All rights reserved.