Welcome to TP-LINK Tech Support Forum
+ Reply to Thread
Results 1 to 6 of 6
  1. #1
    Junior Member
    Join Date
    Apr 2017
    Posts
    1

    Exclamation TC-7610 frequently drops connection to internet

    Model :

    Hardware Version :

    Firmware Version :

    ISP : [/COLOR]

    I have had my TC-7610 modem for several months now, and during the last month or so I've been having intermittent problems with the connection getting dropped. Restarting the modem by unplugging and plugging it back in fixes the problem, until it happens again. Sometimes I can go days with no problem, other times it loses it's connection several times a day. I am using this modem with my Cox Cable internet service, and use it on a variety of devices, including a Windows 10 PC, and via WiFi on a Roku box, Amazon Echo, smart phone, etc.

    I previously used a modem rented from the cable provider, and did not have this problem.

  2. #2
    Junior Member
    Join Date
    May 2017
    Posts
    1
    I just bought one today. I think Its going right back tomorrow after visiting this site. I've spent the last hour trying to register It and there seems to be a problem preventing me from doing that no matter what I do. I don't like anything that doesn't go smoothly.

  3. #3
    Junior Member
    Join Date
    May 2017
    Posts
    1
    I am having the same issue with my connection dropping frequently over the past couple of weeks. No issue before that. Any solution?

  4. #4
    Junior Member
    Join Date
    May 2017
    Posts
    2

    Sounds like the same issue I am having with my CR700 modem router.

    I loose WiFi connection to every device in the house (Amazon echo, Nest thermostat, roku, etc). I unplug for about 10 sec and back to normal for a little while. This just started a couple days ago. Fine for the first 4 mths using it. Researched on-line and others are having similar problems. Fix is either updating driver on devices (doubt every device in the house needs updated at the same time) or updating firmware on the router. Problem is I can't find firmware update on the TP-Link website, unless GPL is the same as firmware. If it is, then I have the latest according to what is posted on the GPL download. Any suggestions?

  5. #5
    Junior Member
    Join Date
    May 2017
    Posts
    2
    I have the same issue with my CR700 modem router. Worked great for about 4 months, then a couple days ago started losing WiFi connection to every device in the house (Echo, Nest, Roku, etc...). Haven't had time to mess with it, so just been resetting (unplug for 10 sec). Logged into router this morning and everything seems fine. Checked for firmware updates on the TP-Link website and I have the latest firmware release (assuming GPL is the firmware). Has anyone found resolution to this yet?

  6. #6
    Junior Member
    Join Date
    Aug 2016
    Posts
    1
    My problem with the TC-7620 version is that it wont hold the IpV6 connection and the system log shows error: No ranging response - time out error. No help from TP-Link. Technology has become all about the sale, there is no focus on customer service and technical support. We are forced to send back, take back and trial and error until you get something that closely works as advertised.


 

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts

Copyright 1996-2017 TP-LINK Technologies Co., Ltd. All rights reserved.