Welcome to TP-LINK Tech Support Forum
+ Reply to Thread
Results 1 to 9 of 9
  1. #1
    Junior Member Mr.Shelby is on a distinguished road
    Join Date
    Apr 2017

    PLC Utiliy recognizes TP-PA8030P as an unknown device

    Model :

    Hardware Version :

    Firmware Version :

    ISP : [/COLOR]


    I have a TL-PA8030P KIT connected and running with an AVM FritzBox 7490. Everything runs smooth, there is only one problem. I am not able to update the kit. The PLC Utiliy recognizes the powerline adapters but only as unknown devices. The only option I can choose is to rename them.
    Any idea what to do?

  2. #2
    Same here. I've used the old PLC utility that came on CD with the adapter. That worked - and the downloadable tpPLC utility still doesn't to this day.

  3. #3
    Would you upload the old version? Seems I dont have the CD anymore.

  4. #4
    Try a hard reset?

    Or If there is newer firmware then use the recovery utility I posted elsewhere on here and update it.

  5. #5
    The problem is with how tpPLC guesses which adapters are TP-Link product and which aren't. Unlike ALL the other vendors, TP-Link PLCs do not have the "vendor" and "product" fields filled correctly - this is a firmware problem. Instead, the "unit name" field is filled with a string that reads "tp_ver_...". tpPLC utility looks for that string.

    Now if you rename your PLC adapter units with a generic PLC management tool, TP-Link adapters become unrecognizable, only a factory reset ever brings them back.

    To get this right, TP-Link would have to configure their firmware correctly. Note this is true across all series that use Qualcomm chips - AV200, AV500, AV1200.

  6. #6
    OK, so a hard / factory reset as above then. To do that, repower the Powerline adaptor and hold down the sync button for about 15 seconds...

  7. #7

    In my case my FritzBox could reset the powerlan adapter

    I got the same problem as you described, my TP-Link PowerLan Adapter was shown as unknown device in tie PLC-Tool.
    But I remembered that I found the PowerLan Adapter in my FritzBox home network. I looked in my Fritzbox home network overview, found the PowerLan Adapter and in the detail page, there was a reset button. After I reseted the PowerLan Adapter, the PLC-Tool found the Adapter as a tp-link device. Now, it works.

  8. #8
    ... and once you name the TP-Link adapter using the Fritz!Box user interface, it'll be "unknown" to TP-Link software again. See above for why.

  9. #9
    No, I only reset the powerline adapter via Fritzbox menu. After the reset, the adapter was correctly shown in the PLC-Tool.


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts

Copyright 1996-2018 TP-LINK Technologies Co., Ltd. All rights reserved.