Model :

Hardware Version :

Firmware Version :


I am trying to set up an AV500 wifi power line extender with SSId/pw clone feature. The power line capability seems to work fine across different sockets in my home. The "build a new wifi network" also works well - I can connect to the "tp..." SSID fine and connect to the internet via the power line network. What doesn't work however is the clone feature. I cannot get my AV500 to clone my existing Ssid and password. The wifi light flashes fast after I followed the clone instructions, but all it does is "build a new wifi network" where on my devices I still have to enter the TP link ssid and password. I have tried resetting my AV500 wifi power line extender and also my router. I have changed the default router password as also instructed on the Tp link website. I have tried "forgetting my network" on my devices. But none of these steps seems to make any difference. When I take the av500 to the remote power socket it always displays on my devices with the TPlink Ssid, not my BT homehub ssid. I always attempted the cloning with the devices very near each other.I was confused that I haven't seen the "slow LED flash" on the wifi button on the av500. When on, it always flashes quickly for me. Many thanks for your help on the above. James.