Welcome to TP-LINK Tech Support Forum
+ Reply to Thread
Results 1 to 5 of 5
  1. #1
    Junior Member
    Join Date
    Apr 2017
    Posts
    1

    Solved: Extender Connectivity Issues & Reboots

    Model :

    Hardware Version :

    Firmware Version :

    ISP : [/COLOR]

    I purchased the RE580D range extender a couple weeks ago to extend my 5Ghz network (the wifi router is a TP Link Archer C7).

    After installing the extender I had great connection speeds, but unfortunately after a day or so of connectivity, the Internet connection would completely drop between certain devices and the extender. Rebooting the extender was the only way to fix the problem, which was not ideal.

    I read some other posts on this forum with similar issues, and I think I have found a solution that I wanted to share with this forum.

    In short, follow the instructions outlined in this support document: http://www.tp-link.com/us/faq-943.html
    so that your connectivity goes FROM this (bad): wifi_router <=== 2Ghz & 5Ghz ==> wifi_extender (extends network on 5Ghz)
    TO this (good): wifi_router <=== 2Ghz ====> wifi_extender (extends network on 5Ghz)

    My wifi extender speeds stayed the same (to my surprise) even just at 2Ghz, and the wifi extender is much more robust now for both wired and wireless clients.

    My guess is that there is a bug in the extender so that 5Ghz connectivity to the wifi router get into a funky state, and the extender cannot recover without a reboot.

    Hope this helps someone else!

  2. #2
    Have just finished writing a post where I have near identical problem (post yet to appear). Will try your solution.

  3. #3
    I installed this same model RE580D four days ago and have had precisely the same problem. For one person to have a problem might be dismissed as random, but for three to have the same issue suggests this is indeed some sort of firmware issue.

    But yes, I had precisely the exact same issue - I had an IPTV client connected at 5 Ghz and then mysteriously after one day of absolute perfection the RE580D goes into some weird unrecoverable passive hibernation with only a power light showing and the other four LEDs completely unlit. And like the OP, only a full re-boot fixes it.

    I actually tried it on 2 GHz only before even finding this forum let alone this thread. Based on what I have now read, I hope this works, but I only did this 6 hours ago. But just as importantly, it would seem that this device has some sort of 5 Ghz issue.

  4. #4
    OMG!! thank you so much for this post! I experience the same issue and definitely is the firmware that is causing the issue... I have to use US firmware ( i stay in singapore which is the UK) in order to minimise the lost connection when i use 5Ghz

  5. #5
    Just something else I have tried, since I want to stay on the 5 Ghz band only - the 2.4 Ghz band at Mum's house where the RE580D is installed is incredibly congested.

    I disabled DHCP server on the RE580D which is set to "auto" by factory default. Then I reduced the 5 Ghz bandwidth from 80 Mhz to 40 Mhz on the main router. So far I have set a record of 4 days up time with absolutely zero problems. I will update this thread if it falls over again (and there was nothing wrong with the actual network that would account for it).

    Yes, the side effect of doing this is that speed has been halved, however in Mum's case, the current speed is still more than 4 times as fast as Mum will ever need in her lifetime (she is 78), since it only needs to run as fast as her internet connection (which because of technical limitations here in Australia will likely never exceed 100 Mbps in her lifetime).

    I just hope what I have done works, since this has been a frustrating experience and the 2.4 Ghz band is way too interference prone, with often up to 12 signals coming through on the same channel. At 5 GHz, the band is presently virtually unoccupied save for a couple of other neighbouring properties.


 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts

Copyright 1996-2017 TP-LINK Technologies Co., Ltd. All rights reserved.