Model :

Hardware Version :

Firmware Version :

ISP : [/COLOR]

Here is an email I sent to NordVPN support. Has anyone ever gotten this to work?


I would like my router to provide the VPN connection to the NordVPN server so all wireless devices in my house get it by default. I've read the article on connecting TP-LINK routers via L2TP and adapted it to the Archer CR700 (whose setup screen isn't quite the same as that in the article). However, after the required reboot, there is no internet connection. I have to set connection type back to Dynamic IP. Here are the applicable fields from the CR700 admin page:
First I go to Advanced=>Network=>WAN
Connection Type: L2TP(Dynamic IP) (Other choices are: Dynamic IP, Static IP, L2TP(Static) )
User Name: myregisteredemailwithnordvpn@yahoo.com (NordVPN login credentials seem to be only email address, no usernames)
Password: my password (this is correct... I have not miskeyed this)
Server IP Address/Name: us50.nordvpn.com (your server list says it supports L2TP... I've tried several)


There is then a radio button for MAC Clone:
Choices are:
Use Default MAC Address
Use Computer MAC Address
Use This MAC Address which has a box to enter address.


I leave this at the default first choice.
Only button left to press is "Apply" after which it requests a reboot for the new settings to take effect. After reboot, there is no internet connection, nor is wifi enabled. I have to hardwire into the router to reset to Dynamic IP and after that reboot, all is working again.

Any thoughts? Thanks!