Welcome to TP-LINK Tech Support Forum
+ Reply to Thread
Results 1 to 14 of 14
  1. #1

    Unhappy CPE210 TX Rate drops to 1Mbps

    Model :

    Hardware Version :

    Firmware Version :

    ISP : [/COLOR]

    Hi all, I've got a CPE 210 v1.1 connected to my ISP router in Client Mode at 250m, TX/RX rates are 130Mbps, I think it's the max rate of my ISP router but after a while (could be minutes/hours) the TX Rate on CPE 210 drops to 1Mbps until I reboot it. Any idea why? I can provide more details if needed. Thanks in advance

  2. #2
    New firmware http://static.tp-link.com/TP_PharOS_2.0.0_161117.zip
    Display wireless settings

  3. #3
    That's the firmware I have, Release 38185MAXtream: OffRegion: Test_ModeChannel: 1Width: 20/40mhzMode: B/G/N MixedMax TX Rate: 300MbpsTransmit Power: 27dbmDistance: 0.2km

  4. #4
    Members R1D2 is on a distinguished road
    Join Date
    Dec 2015
    Posts
    1,205
    Quote Originally Posted by yandoo View Post
    That's the firmware I have, Release 38185MAXtream: OffRegion: Test_ModeChannel: 1Width: 20/40mhzMode: B/G/N MixedMax TX Rate: 300MbpsTransmit Power: 27dbmDistance: 0.2km
    TX/RX rates are dynamically negotiated between both devices. If the rate drops to 1 Mbps this means that the radio link is of a very bad quality. Much more significant then TX/RX rates are signal strength, noise strength, signal-to-noise ratio (SNR) and transmit CCQ shown on the status page of the CPE.

    1 Mbps is probably negotiated b/c of fall-back to 802.11, a very ancient standard included in 802.11g.

    First of all, set channel width to 20 MHz only. 20/40 MHz mixed mode means that the CPE tries to use up to 8 channels simultaneously - hopeless in today's 2.4 GHz band (except if you are living in the jungle or in outer space).

    Next, set wireless mode to 802.11n only, if your router supports n mode. If not supported by your router, set it to 802.11g or 802.11b/g. If the radio link is bad (due to TX power of your router's antennas, which almost certainly don't match the characteristics of the CPE's directional antennas), then n mode will not work at all even if your router supports it. You can find out by setting a fixed mode as described.

    BTW: 27 dBm with CPE's 9 dBi antennas gives you 36 dBm radiation power in total (that's 4 Watts or 4,000 mW). 4 Watts is o.k. for 10+ kilometers as long as regulatory authority of your country allows it at all, but over a distance of 250 meters it is like talking to a person standing beside you with a megaphone. Try to use 11 dBm TX power (yielding 100 mW) or 14 dBm (200 mW) and increase until you find best signal rate/noise strength/SNR. Note that exceeding the legal limit can get you into big trouble, not only of technical nature.

    Also important: carefully align the directional antenna of the CPE to the antenna(s) of your router.

    Compare signal rate/noise strength/SNR between each setting while you change them. This is how to calibrate your radio link by trial and error.

    If you still can't get more than a few Mbps out of your link, you are probably living in a very dense populated area with some dozens of 2.4 GHz APs in your neighborhood. Then all bets are off: too much interferences. If there are not that much APs around, but still no improvement by above measures, consider use of a second CPE at your router's side for the radio link. It will greatly improve the quality of the radio link, but still all variations of settings described above will apply to such a setup, too.
    Last edited by R1D2; 04-03-2017 at 23:01.

  5. #5
    Thank you, I'll try some settings. And yes there are around 30 AP on CPE wireless survey so I thought if I rise it to 27dbm I get a better signal. Some neighbors have Yagi antennas outside. My problem is not the speed of internet (when it don't drop to 1Mbps), I got 60d/20u at home and ~50d/20u in CPE.

  6. #6
    Members R1D2 is on a distinguished road
    Join Date
    Dec 2015
    Posts
    1,205
    Do your neighbors also use 4 watts TX power? Then that would pretty much explain casual drops back to 1 Mbps.

  7. #7
    I don't know, but I can see a Yagi antenna in his rooftop

  8. #8
    Members R1D2 is on a distinguished road
    Join Date
    Dec 2015
    Posts
    1,205
    Try to find the most unused channel. Note that in n mode using OFDM modulation, the CPE will use 4 channels @20 MHz channel width, so be sure to set it to 4 channels apart of your neighbor's device if possible (e.g. on ch 1, 5, 9 or 13).

  9. #9
    I've tried different settings but after a while the TX rate goes down to 1Mbps in all. I've attached a screenshot from spectrum analysis but I don't know how to interpret the graphic. Tomorrow I'll talk with my neighbors and see if they can help somehow
    Attached Images  

  10. #10
    Members R1D2 is on a distinguished road
    Join Date
    Dec 2015
    Posts
    1,205
    Quote Originally Posted by yandoo View Post
    I've attached a screenshot from spectrum analysis but I don't know how to interpret the graphic.
    It means that channel 5 (2432 MHz) is the best channel, while channels 9 to 13 are overcrowded or have interferences.

  11. #11
    QoS Enable.
    Use cable FTP

  12. #12
    Junior Member makismao is on a distinguished road
    Join Date
    May 2017
    Posts
    1

    disable firewall

    Hello friend. I was having this problem for months and now I think I have found the solution. For the past 5 ours I am having almost stable 72.2Mbps in both TX and RX. Please go your CPE210 panel to network tab and under security section uncheck the SPI Firewall box. I hope to work for you like it worked for me

    Quote Originally Posted by yandoo View Post
    Model :

    Hardware Version :

    Firmware Version :

    ISP : [/COLOR]

    Hi all, I've got a CPE 210 v1.1 connected to my ISP router in Client Mode at 250m, TX/RX rates are 130Mbps, I think it's the max rate of my ISP router but after a while (could be minutes/hours) the TX Rate on CPE 210 drops to 1Mbps until I reboot it. Any idea why? I can provide more details if needed. Thanks in advance

  13. #13
    Quote Originally Posted by makismao View Post
    Hello friend. I was having this problem for months and now I think I have found the solution. For the past 5 ours I am having almost stable 72.2Mbps in both TX and RX. Please go your CPE210 panel to network tab and under security section uncheck the SPI Firewall box. I hope to work for you like it worked for me
    I don't have that options. My problem was caused by too many networks around me and after a talk with my neighbors we agreed to set different channels. It still happens sometimes but it is way less frequent now

  14. #14
    Members R1D2 is on a distinguished road
    Join Date
    Dec 2015
    Posts
    1,205
    Quote Originally Posted by yandoo View Post
    I don't have that options. My problem was caused by too many networks around me and after a talk with my neighbors we agreed to set different channels. It still happens sometimes but it is way less frequent now
    Don't worry! SPI firewall option is only visible in AP router mode or AP client router mode and no, I would not recommend to disable the firewall if using router mode to isolate a network ...

    As for the drops in TX/RX rate: this is absolutely normal. It's switching between current offered speed and negotiated speed with clients. Take for example the SSID beacons: they are always sent at the lowest mandatory speed that is configured for a wireless network. Therefore, in b/g mode 1 Mbit/s is the lowest mandatory speed, so beacons are sent at 1 Mbit/s. If you use n mode only, beacons are sent at 6 Mbit/s, so those drops will go down to 6 Mbit/s. SInce beacons are sent 10 times a second, those drops occur 10 times a second.

    If the quality of the link is bad, drops can go to 11, 54 or 72 Mbit/s even during normal data transfer, if link quality is good it goes back to 130 Mbit/s.

    This is what you observe when TX/RX drops. If there are many other devices around interfering with your device, then those "drops" will increase.
    Last edited by R1D2; 05-12-2017 at 21:25.


 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts

Copyright 1996-2017 TP-LINK Technologies Co., Ltd. All rights reserved.