Welcome to TP-LINK Tech Support Forum
+ Reply to Thread
Results 1 to 7 of 7
  1. #1

    Kasa App - Max Wi-fi Password Length is 30. Need more!

    Model :

    Hardware Version :

    Firmware Version :

    ISP : [/COLOR]

    Just installed two HS200 switches today and discovered Kasa has a max wifi password limitation of 30 characters. When typing the password the entry just stops at 30. This seems like an arbitrary limit coded by the developer and needs to be increased as WPA2 passwords can be up to 63 characters. Since my password is >30 I'm unable to configure the switches to connect to my network. I confirmed I can connect with shorter passwords by setting up a guest network with a

  2. #2
    rest of post: ...with a less than 30 character password which worked fine. TP-Link, please address this ASAP! It seems like it would be an easy fix and I'm dead in the water until you do. (Shortening my password isn't an acceptable option).Thanks!

  3. #3
    We have tested it, but there is no same issue.Please confirm you have updated KASA APP to the latest version and test again. If there is still same issue, please provide the screenshots of the error message, the encryption and password of the router's wifi. We will test it again.

  4. #4

    I ran through the setup again and discovered when choosing a network from the list of available networks, the app limits the password field to 30 characters. If, however, manual entry is chosen and the SSID and password are entered via that option, the password field WILL accept greater than 30 characters. This is Kasa version 1.7.4, build 405.

  5. #5
    The issue has been confirmed on the 1.7.4 version of Kasa, it will be fixed in the next version of iOS Kasa(1.7.5). Thanks.

  6. #6

    30 character length limit not fixed in Kasa V1.7.5 build 407

    I have encountered the exact same problem described above, and am running the latest Kasa release 1.7.5 build 407. Can you please update us on when this will be fixed?

  7. #7
    Junior Member ycardon is on a distinguished road
    Join Date
    May 2017

    Lightbulb a workaround

    Same problem here, but I did worked around the problem by not setting the wifi credentials through the mobile app but from a python script.

    if you're command line skilled, this is what I did :
    1. opened a temporary guest network on my router, with a password "less than 30 chars"
    2. registered the plug through the Kasa app on this guest network, retrieved the IP assigned to the plug via my router
    3. went to https://github.com/softScheck/tplink-smartplug - btw, they have a nice analysis on the solution security
    4. switched from my computer to the guest network
    5. launched the tplink-smartplug.py with the {"netif":{"set_stainfo":{"ssid"... command
    Worked like charm : the 30 chars password limitation is only in the mobile app, not on the device itself.

    Hope it helps,


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts

Copyright 1996-2018 TP-LINK Technologies Co., Ltd. All rights reserved.