Welcome to TP-LINK Tech Support Forum
+ Reply to Thread
Page 1 of 2 1 2 LastLast
Results 1 to 15 of 17
  1. #1

    Serious question about TD-W8960N V7

    Model :

    Hardware Version :

    Firmware Version :

    ISP : [/COLOR]

    Hello, 2 weeks ago i bought a TD-W8960N V7 , i wanted to know if there is a firmware update for this.. currently i am running on 1.0.9 Build 160614 Rel.41323 .. i am facing some issues with my internet connection and hopping that a firmware update would fix it. Thank you !!

  2. #2
    Banned
    Join Date
    Jan 2013
    Posts
    2,567
    Are you sure that the problem with router firmware?

  3. #3
    There is no newer firmware than what you can find on TP-Link homepage. 160614 ia allready the newest as I can see. see here

  4. #4
    hello, for v7 i dont see any firmware update

  5. #5
    i didnt say that the problem is with the firmaware, i just told that maybe a firmware update could solve my problem..

  6. #6
    what the issue cause your problem???

  7. #7
    Banned
    Join Date
    Jan 2013
    Posts
    2,567
    Sorry We don't know kind of your problems with internet connection.

  8. #8
    Quote Originally Posted by stanleyhock View Post
    what the issue cause your problem???
    hey, i have 8-12 mbps.. but some sites wont opening.. i tried multiple dns servers but nothing changed.. called to my ISP they couldnt identify the problem.. with my past modem i didnt had problem.. just want to buy a new one. and i bought this, but now i am facing problems with my internet connection.. i am using a 10 meter ethernet sometimes and other times using a wireless usb ..

  9. #9
    Hello, you can try to modify the MTU value on your PC. You can type the command in the screenshot.Name:  mtu modify.jpg
Views: 0
Size:  77.5 KB

  10. #10
    Quote Originally Posted by Pacoo View Post
    Hello, you can try to modify the MTU value on your PC. You can type the command in the screenshot.Attachment 4909
    ok i typed it.. if i dont answer means that everything is fine
    Last edited by StonebridgeGR; 03-22-2017 at 18:53.

  11. #11
    nothing changed.. again the same problem :/

  12. #12
    Banned
    Join Date
    Jan 2013
    Posts
    2,567
    Can you show me ipconfig /all in cmd

  13. #13
    Quote Originally Posted by jimasek View Post
    Can you show me ipconfig /all in cmd
    yes, this is while i am connected with ethernet cable http://prntscr.com/eodf8p


    a
    nd this while i am connected wireless http://prntscr.com/eodfwj

  14. #14
    Banned
    Join Date
    Jan 2013
    Posts
    2,567
    Please enter DNS addresses in DNS Server Configuration, for example 8.8.8.8 and 8.8.4.4 or DNS from your ISP. After that please click Save and reboot your router.

  15. #15
    Quote Originally Posted by jimasek View Post
    Please enter DNS addresses in DNS Server Configuration, for example 8.8.8.8 and 8.8.4.4 or DNS from your ISP. After that please click Save and reboot your router.
    like i said i tried many times these dns servers.. and my isp's too .. but nothing changed.. here on the quick setup what i am supposed to chose ? my isp wont helping me much about my internet problems ..

    http://prntscr.com/eryz4i


 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts

Copyright 1996-2017 TP-LINK Technologies Co., Ltd. All rights reserved.