Welcome to TP-LINK Tech Support Forum
+ Reply to Thread
Page 1 of 3 1 2 3 LastLast
Results 1 to 15 of 41
  1. #1

    Echo - suddenly no TP Link devices responding

    Model :

    Hardware Version :

    Firmware Version :

    ISP : [/COLOR]

    Have been using Echo Dot with about a half dozen TP Link smart plugs for a few months. Today, for no known reason, nothing is responding via Echo.

    Alexa responds to all requests (for all six devices):
    "Sorry the device NAME is not responding"

    I CAN control all the devices from my Kasa app on my phone.
    All the devices are listed under the Alexa web app
    I restarted the ECHO
    I used the ECHO/Alexa web app to "discover devices" (even though they all appeared)
    I disabled the TP-Link skill, re-enabled it, discovered devices...

    Still not working.

    It is not exactly evident which product is failing here.
    Can someone please recommend some troubleshooting steps or a fix?
    Thank you

  2. #2
    Junior Member ShadowDrakken is on a distinguished road
    Join Date
    Mar 2017
    It's the connection between the TP-Link Kasa skill on the Echo and the TP-Link servers. I removed the skill and when attempting to re-add it, I'm getting "500 Internal Server Error" during logon. So it's 100% on TP-Link's end.

  3. #3
    Junior Member itsbenaltogethe is on a distinguished road
    Join Date
    Mar 2017
    pretty much the same for me

  4. #4
    I'm having same problem, any solutions?

  5. #5
    Junior Member Gman2K17 is on a distinguished road
    Join Date
    Mar 2017
    Same problem here. Exactly the same problem. All devices (8) work fine with the Kasa app on phone, but Alexa responds to all request with "Sorry, the device NAME is not responding". I am also now getting "That command doesn't work on device NAME" The command is question is simply "Turn on NAME" or Turn off NAME" Just started today (March 2nd 2017). Must be a major failure on the Network link between Amazon and Kasa! I will wait it out and see if it restores itself. I had issues with the Wifi Thermostat yesterday with Alexa and it corrected itself.
    Thinking this may have something to do with Amazons S3 service outage that was reported yesterday.

  6. #6
    Having the same issue. Tried to delete one of the items out of my phone app and got a message that said the app couldn't connect to the server. Everything is showing up as local wife control only, though yesterday everything worked fine.

    To be honest, I think the Kasa service is messed up....

  7. #7
    Junior Member ndd is on a distinguished road
    Join Date
    Mar 2017
    I am having the same issue with 4 HS200 switches. I can turn them on and off with my phone as long as I am on the local network. When I try remotely, from my phone network, it says devices cannot be found try again later. When I disconnected tplink from alexa and tried to reconnect it, I get an internal server error.

    My guess is that there is a problem with the tplink site.

  8. #8
    Junior Member 2ndsteel is on a distinguished road
    Join Date
    Mar 2017

    Same Issue

    I have two bulbs, one switch and one plug. Until today all worked with ECHO dot, now ECHO does not recognize any of them. They work fine with the KASA app. Any help would be appreciated.

  9. #9
    Junior Member Nightbender is on a distinguished road
    Join Date
    Mar 2017
    Check your devices in the Kasa application. Are they in 'Local Only' mode?

  10. #10
    Me too! To make matters worse, I disabled the skill on my Echo Dot and think a fresh enable would kick it back into working order but now I can enable the skill at all. Very disappointing.

  11. #11
    I have the same exact problem as Deke. What is going on. Can someone help?


  12. #12

  13. #13

    It's happening to hundreds, if not thousands.

    It's probably not you, I think something gets broken upstream every so often.
    Last edited by ronabop; 03-03-2017 at 07:11.

  14. #14
    Junior Member bosmommy is on a distinguished road
    Join Date
    Mar 2017
    Was up until 3AM thinking the problem was on my end! I kept trying to reset the 3 smart plugs I have! I didn't receive an email until the issue was resolved from TP!

  15. #15
    I did hear from TP-Link here is what they said,Dear Kasa User:

    We recently learned that users are experiencing an issue when using the Kasa app remotely and/or with Amazon Alexa Voice Control. Users are reporting receiving these error messages:
    • 503 Service Temporarily Unavailable
    • Server internal error
    • Amazon Alexa voice control error stating, Sorry, the device is not responding. Please check its network connection and power supply.
    Our smart home team is working diligently to identify and resolve this as quickly as possible. We sincerely apologize for the inconvenience and appreciate your patience as we work to resolve this issue. We will email you again when we have an update.


Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts

Copyright 1996-2018 TP-LINK Technologies Co., Ltd. All rights reserved.