Welcome to TP-LINK Tech Support Forum
+ Reply to Thread
Results 1 to 10 of 10
  1. #1

    Where is the support for Archer VR900!?

    Model :

    Hardware Version :

    Firmware Version :

    ISP : [/COLOR]

    How can this router not be compatible with the tether app? It's not even an old router yet there is no cloud binding option in the routers web interface, no recent firmware release in UK and the tether app doesn't even allow you to login !The website states the vr900 is compatible, which is not true. I've tried to email support, but after filling out the form multiple times it just says submission failed and clears all text - very annoying.
    Last edited by Hav; 02-06-2017 at 09:04. Reason: Tidy up

  2. #2

  3. #3
    Thanks for the reply.

    I'm aware of the latest firmware version, but that's the problem... it's from March last year.
    It allows no compatibility with the Tether app since it was updated to allow cloud access/control.

    It's not as if this is a 5 year old budget router, i don't understand why there has been no update to allow me to simply acces the router via the app.

  4. #4
    I agree.In the past TP-Link were good with supporting their products. Now they seem to just release as many new products as possible without much thought for support on existing products.
    I also have the VR900 (v1) and the firmware has many bugs. From USB support to wi-fi issues.
    It's a shame, I won't buy from them again.

  5. #5
    I have an Archer VR900 V1 - and also on plusnet before the update.

    I've had no end of bother from it. Even being unable to enter the admin area without rebooting first before it times out trying to find it. (my recent first post is regarding this).

    The router is up to date, but recently I had to do a factory reset as a lost resort. This has currently stopped the timeouts access the admin, but also, now displays the router in the tether app.

  6. #6
    Interesting. You say you can see the router, but can you actually log into it with the app? My router shows up and asks for a password, then just says Login Failed after entering it.
    I have an on going ticket which this morning was escalated to a senior engineer
    I'm not exactly hopeful but i'll let you know how it goes.

  7. #7
    Before the factory reset, I couldn't see the router in the tether app. After the reset it appeared, and yes, I could login with the password - admittedly, it times out very quickly and has to search for the router again. Not the best app, the responsive interface of the admin panel is pretty good though, but yes, you have to type in the IP address in the url.

    The main thing is, I can still login to the admin portal without having to turn the router on and off - this is day three. BoOm!

  8. #8
    Thanks.I backed up my router settings today and did a reset like you mentioned and to my surprise the tether app worked straight away... Although when I restored my router config it refused to connect again.Something's not right =/ I either need to find the setting in my current config which is not allowing tether to work, or set my router up from scratch; which is like to avoid

  9. #9
    The only logical way to debug is to slowly build your settings back up until it breaks.

  10. #10


    I know

    I actually did it all from scratch after i posted that and the app carried on working just fine.
    Something in my original config was stopping tether working and i have no idea what it was... to be honest maybe i should just leave it and forget it happened


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts

Copyright 1996-2018 TP-LINK Technologies Co., Ltd. All rights reserved.