Welcome to TP-LINK Tech Support Forum
+ Reply to Thread
Results 1 to 9 of 9
  1. #1

    Kasa scheduler no longer working

    Model :

    Hardware Version :

    Firmware Version :

    ISP : [/COLOR]

    I had the Kasa scheduler controlling one of my bulbs and it was working fine. Earlier this week it has given up and the scheduler no longer works for any of my bulbs. I've created new schedules to test them and still no luck.

    Any ideas on what to do next?

    Last edited by Enson Loo; 03-14-2018 at 01:48.

  2. #2

    Not working for me either

    I had a repeating schedule I used and it no longer works. I use a bulb as my alarm clock so there was one morning of freaking out when it didn't turn on. I've played around with it and it seems like I can get one to turn on if I do a one-time schedule, but no repeating schedules will work

  3. #3
    Strangely, it did work this morning. Will it work next time?

  4. #4
    Same Problem

    I am also experiencing problems with the scheduler. From the looks of things, it appears that some of my Smart Bulbs are confused as to what time it is. This confusion is probably within the Kasa app in the cloud and not in the bulb(s) itself. Here are a few notes about what I am seeing:
    1. I have 10 LB120s and 1 LB130. They are all connected fine and work great with both the Kasa app and Echo Dot.
    2. I have 5 of these bulbs scheduled to come on a various times/brightness in the morning as part of my wake-up schedule. 3 of them work as scheduled, 2 do not.
    3. When I turn the bulbs ON (via Kasa app, not the scheduler) in circadian mode, the automatic bulb settings (brightness, hue) of the 3 "working" bulbs differs from that of the 2 "non-working" bulbs, which leads me to believe they don't know what time it is.
    4. When I schedule the bulbs to come on at Sunset, the 3 "working" bulbs come on at the right time (as seen in the upcoming schedule icon). The 2 "non-working" bulbs show (via the schedule icon) that they are scheduled to come on way too early. This behavior also leads me to believe that they (or the Kasa cloud) don't know what time it is.
    5. Just to clarify, the bulbs/scheduler worked fine until a couple days ago.

    I tried resetting one of the bulbs with no change in behavior. I'll try again this weekend.

    Is this just a problem with Kasa, and is there a fix in the works?

  5. #5
    I figured out my problem: the bulbs know what time it is, but they have the wrong date and the date can't be changed through the app (from what I can see so far).

  6. #6


    I found this thread, which describes the same problem: http://forum.tp-link.com/showthread....has-wrong-date

    I went to Support and Online Chat and explained the problem and was given a link to download an (Windows only) updater. I was able to update the firmware in the bulb and it is now showing the correct date.

  7. #7
    Junior Member Jarikai is on a distinguished road
    Join Date
    Dec 2017

    Schedules - Cannot connect to server

    Recently found that the schedules I had set within the KASA app for my TP Link smart bulb had disappeared and I had an error message stating that I couldnít connect to the server. Solved the problem by going into the settings for the bulb via the KASA app and re syncing the date and time. Had to resync twice for some reason but it did eventually allow me to Create new schedules. Possibly something to do with the clock changes to n October over as Iím not sure Iíve used the schedules since then?

  8. #8
    Junior Member jwcb is on a distinguished road
    Join Date
    Jan 2018

    Does switching wifi interfere with schedules?

    I'm trying to understand where the control is...does the bulb itself have the schedules once programmed, or is it the cloud, or the app? Without going into too much detail, the bulb moves occasionally from one setting to another but the schedules stop. I'm trying to understand if the bulb isn't working because it can't reach the internet to get commands from the web, or maybe similarly from the app.

    I assumed that once programmed and started in schedule mode the bulb kept going regardless of wifi.

    Can anyone help me understand how this is working so I can adjust my plans?

  9. #9
    Junior Member ctrilla is on a distinguished road
    Join Date
    Mar 2018
    I was frustrated by a similar problem, but have maybe found a solution.

    I have four LB100 bulbs connected to my wi-fi. Two of the bulbs stopped turning on and off via the schedule I specified. I clicked on the icons in the Kasa app, but the bulbs did not show any scheduled on or off times at all.

    Diving into the settings (click on the bulb > then click on the options button in the top right corner) showed that these two malfunctioning bulbs were set to a device time of "01/01/00". In other words, the time was set to the year 2000.

    This can be fixed by going into the Kasa app's settings (the three horizontal bars in the top left of the main screen, NOT an individual bulb's options), navigating into "Location and Time", and either (1) syncing your location by turning on your device's location services OR (2) temporarily resetting your time zone.

    Once I did this, all of the malfunctioning bulbs times were up to date and the previously scheduled on/off times re-appeared in the "Schedule" menu.

    I hope this solution finds you. I was very close to ripping the bulbs out and returning them.

    As for the cause, I haven't experimented yet...but the time reset to the year 2000 might have been caused by my wife turning off the power switch to these 2 bulbs in particular.


Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts

Copyright © 1996-2018 TP-LINK Technologies Co., Ltd. All rights reserved.