Welcome to TP-LINK Tech Support Forum
+ Reply to Thread
Results 1 to 2 of 2
  1. #1
    Junior Member
    Join Date
    Jan 2017

    AC5400: Cannot access router management console

    Model : Archer C5400

    Hardware Version :

    Firmware Version : 1.0.8 build 20170113 rel. 62479 (5553)

    ISP : Starhub[/COLOR]

    Just purchased my new TPL AC5400 router, was very excited to get it up and running.
    Connected to modem and followed the configuration steps, all good.
    Following the routers auto update recommendations upgraded to firmware 1.0.8 build 20170113 rel. 62479 (5553), my HW ver is 2.0
    Changed default PW (as part of the initial config)
    Changed routers LAN address to (all my wired network carries static addresses starting with 192.168.10.x)
    Added no-ip DDNS
    Activated smart connect (all bands carry same SSID)
    Defined 3 ports for forwarding (I think TPL uses virtual server as the term)
    Connected all other equipment on my wired network to the 4 ports in the back
    Restart the router
    Wired and wireless have internet access, no problem.
    Loading the mgmt console with or tplinkwifi takes 10-15 minutes, once loads, entering my PWD and then ENTER does nothing, cannot access the config land page.
    I am able to access the router Tether app with the same login information and interact with the router, no issue there.

    Thought I did something wrong, hard reset, did the same steps above again, ending up with the same results even with a single wired client. (tried the hard reset 3 times, same result each time).
    I think this firmware is broken, but the router will not allow me to roll back to the version posted on the web site, which is older than the one the auto update suggested.

    Very frustrated, $400 router went back to the box, and I'm back with my ASUS till I can resolve this issue.
    Any help will be appreciated.
    Thank you
    Attached Images  

  2. #2
    Just out of interest.....do you have another TP-Link device such as an access point plugged in to your network?

    If you do, temporarily pull it out and check the management page again.


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts

Copyright 1996-2017 TP-LINK Technologies Co., Ltd. All rights reserved.