Welcome to TP-LINK Tech Support Forum
+ Reply to Thread
Results 1 to 6 of 6
  1. #1
    Junior Member
    Join Date
    Jan 2017
    Posts
    1

    TC-W7960 wifi disconnects, wired fine

    Model :

    Hardware Version :

    Firmware Version :

    ISP : [/COLOR]

    I recently purchased a TC-W7960 modem/wifi router to use with my Xfinity service. I've cut the cable cord and am using a streaming service. Unfortunately that service is sporadically affected since my wireless connection drops randomly. Wired connections don't appear to be affected when the wifi drops. I don't actually lose wifi signal but my internet connection is gone. I'll most often have to disconnect and reconnect to get it back stable again. Has anyone else experienced this? I don't see many wifi options that I could tweak to fix this or any firmware update I could apply to address this. Any suggestions would be greatly appreciated.

  2. #2
    Members
    Join Date
    Aug 2016
    Posts
    146
    what about the guest network?
    try to reset it by login to webGUI-advanced-system tools

  3. #3
    I am in exactly the same situation as OP. Bought TC-W7960 for Xfinity, worked well in the first 3 months, but now wifi drops randomly.
    I've figured that wifi usually drops ~10 minutes after I start downloading something large, for example a 3GB game.
    Quote Originally Posted by QAQ View Post
    try to reset it by login to webGUI-advanced-system tools
    Tried resetting, no luck.

  4. #4
    Junior Member
    Join Date
    Feb 2017
    Posts
    1
    [h=2]TC-W7960 sucker loses password. just got it. I guess TP Linkbelt or whatever the outfit is called here saw me coming on this ordeal. Really[/h]broke it off in me from behind. I was all excited too. I got mad and threw it across the room and it hit the wall and now it won't work at all. Some plastic pieces fell
    off but not that much of a mess. I wonder if I damaged it?

  5. #5
    I contacted customer support chat and they suggested changing the 2.4 GHz channel from auto to 1, 6 or 11. It been about 30 minutess, no drops...but let's wait and see.

  6. #6
    Junior Member
    Join Date
    Apr 2016
    Posts
    2
    just changed my WDR4300 to channel 6. which has the same issue of daily random WiFi outages. Please post if your change has helped.


 

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts

Copyright 1996-2017 TP-LINK Technologies Co., Ltd. All rights reserved.