Welcome to TP-LINK Tech Support Forum
+ Reply to Thread
Results 1 to 15 of 15
  1. #1
    Junior Member Merandy is on a distinguished road
    Join Date
    Dec 2016

    Angry Smart Plug / Switch / Light Bulbs Not responding to Amazon Echo

    Model :

    Hardware Version :

    Firmware Version :

    ISP : [/COLOR]

    (Posting here because there is no Smart Switch Forum)

    I have:

    5 Smart Switches
    4 Smart Bulbs
    1 Smart Plug

    Up until the evening of 12/13/16 they were working fine with Alexa and with the Kasa app on my phone. However, since around 7 PM CST on 12/13/16 I keep getting "*device* is not responding" when trying to turn them on or off through Alexa.

    I've already done the following:

    "Forgotten" all devices and re-discovered through Alexa app.
    Disabled Kasa skill, "forgotten" all devices, re-enabled Kasa skill, re-linked account, and re-discovered all devices through Alexa app.
    Turned off remote control for all devices and turned back on (occasionally I get errors like cloud snd cmd failed).

    All of these worked to a limited extent - by that I mean I was able to turn on one device (random) once. I could not turn it back off. I had the most luck with disabling remote control and re-enabling, but even that does not really work. The problem is on the TP-Link side - all of my other smart devices work fine with Alexa. I've tried contacting support, but they haven't responded. I am getting very frustrated because the Alexa integration is a BIG part of why I bought all of this stuff.

    Anyone have any suggestions for something else to try?

  2. #2
    Mine too was working flawlessly up until two days ago (26th December).

    Alexa acknowledges the command and says "Ok" but nothing happens.

    Deleted the Alexa Skill, re added - no joy.

    Deleted and re-added the plug - nothing.

    Deleted each plug from the "Connected Devices" section of Alexa - re scanned, now she cannot find EITHER of the plugs whatsoever, and yet they work fine from within the TP-Link Kasa App, so I think its definitely something on the TP-Link side.

  3. #3

    How did you enable remote on your smart switch

    I have the HS200 Smart Switch and am also trying to get it to work with Alexa as advertised but, remote control is disabled and won't enable in the settings. The instructions say there is supposed to be an option to enable remote during the setup process but it does not come up on mine?

  4. #4
    Junior Member glt is on a distinguished road
    Join Date
    Dec 2016
    Ooh, now you are scaring me. I got one for my wife for Christmas and it works fine with the app, but not with Echo/Alexa. I followed the instructions very carefully, over and over. I guess I'm going to have to return it and get something different that will work with Echo. I'm surprised these folks don't have a support phone line.

  5. #5
    It was working perfectly, just stopped. Nothing has changed my side at all.

  6. #6
    I am now having this same problem 2/28/17. Was there a solution?

  7. #7
    Junior Member sarahp is on a distinguished road
    Join Date
    Mar 2017
    same here -- I have three minis, everything has been working perfectly for about 2 months. Today, they weren't responding to Alexa. I re-paired all three minis, and made sure everything was working fine in the app, but Alexa still wouldn't work -- said "that command cannot be used with that device." I had Alexa "forget" them, and now it won't re-discover them. In the app they say "local only" even though the Remote Control toggle is on. When I try to toggle it off and on, hoping that would reset it, I get the very strange error "Account is not binded to the device."

    nice to know I'm not the only one having a problem -- I hope there's an answer soon!

  8. #8
    Junior Member Nightbender is on a distinguished road
    Join Date
    Mar 2017

    Same issue

    Been working fine since I bought the 3 HS105's. 0 Issues.
    No updates to either application, firmware, or router.
    Tonight they are all stuck in local only mode, and won't re-enable Remote Control. Which of course means Alexa can't do anything with them.

  9. #9
    I'm having the same trouble too. I'm thinking it's a server issue that needs to be fixed on their end. But I'm not sure if it's a TP-Link issue or an Amazon issue. I just want it fixed.

  10. #10
    My system was working fine from November to Feb 28, 2017. Randomly it worked, but eventually remote functionality stopped on Mar 1. Everything worked fine from within KASA, but not with the Amazon DOT. I deleted KASA and re-installed. Using the KASA app I had it re-discover my devices and everything works fine from within the KASA app, but when trying to activate the KASA skill in the Alexa app I keep getting an internal server error when I transmit my user name and password. I tested Alexa's ability to get to the cloud and all locations and functions operated normally. I just can't get the KASA app to authorize the functionality of that Alexa skill.

  11. #11
    Junior Member Jtron is on a distinguished road
    Join Date
    Mar 2017
    Mine also stopped working today. In the App each device says "local only" and nothing will work with Echo. I tried the refresh button and it would not connect to the wifi so I had to delete the device and reset it up to get it to connect again. Very frustrating

  12. #12
    In reference to my last post my system came back on line in the wee hours of this morning. Up until then I kept getting server errors. In as much as I have no servers that I can control I can only surmise this was TP-Link cloud services that were having a problem. It gives me pause to try anything that is associated with the cloud. Moving on... the system worked well all day until just a few minutes ago (3:45 PM). It died again. My thought now is why would I buy any more TP-Link products if these few keep failing. The Alexa app runs smoothly for all other things. It's just TP Link that's failing all of us.

  13. #13
    Since I can't trust the TP Link system to operate flawlessly I just cancelled my Amazon order for several more devices. I didn't wish to throw good money away to a flawed system.

  14. #14
    Really poor communication by Amazon and TP LInk here. There was an Amazon could issue that was quite significant. I emailed TP and they told me about this. Then I receive an email from TP about resolving an issue. that is written for help desk dweebs, not consumers. Seriously, when will these people " get it."

  15. #15
    Amen, deke. It's hard to keep the faith without any communication. My system is running again, but I'm cautiously optimistic. I'm having a wait and see attitude before I make the decision to expand my devices. Good luck to all of us.


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts

Copyright 1996-2018 TP-LINK Technologies Co., Ltd. All rights reserved.