Welcome to TP-LINK Tech Support Forum
+ Reply to Thread
Page 2 of 2 FirstFirst 1 2
Results 16 to 22 of 22
  1. #16
    Quote Originally Posted by bdhamm View Post
    this worked for me also.. I agree it is a BAD solution as my wireless signal sucks where my xbox one is in the house and i cannot move the modem closer... they need to fix this problem SOON.
    As far as I can tell, they haven't even acknowledged the problem yet.

  2. #17
    Thank you very much for your email requesting information about our product and sorry for any inconvenience caused.

  3. #18

    got a reply, but it doesn't help at all.......

    Dear Brian,
    Thank you very much for your email requesting information about our product.

    We have already released an official firmware for this issue.
    However , the cable modem is a little special. We need to send this firmware to the internet service provides at first. After they test it and make sure that is working fine with their server. They will update it for you on their side.

    We are not sure the exact time when they will finish the test and update it for you.
    You can also try to contact your internet service provider for detailed information.

    Sorry for the inconvenience caused, and have a nice day.

  4. #19
    Junior Member
    Join Date
    Apr 2017

    Exclamation Same

    It's been 4 months since this problem started, how long does it take for an ISP to clear the firmware?

  5. #20
    Sssoooo... no way of knowing when my ISP does push the update beyond me periodically checking ???

  6. #21
    Junior Member
    Join Date
    Apr 2017
    I have to push on this issue also. It is becoming ridiculous. TWC is not cooperating. They will not tell me what the latest approved firmware version is so that I may compare it against what I currently have. They will not acknowledge whether or not they are even testing a firmware update. I am getting zero support on the ISP side.

    Also, can someone at TP-Link please confirm if a firmware fix has also been issued for the TC-W7960? So far I only see discussion of the AC1750.

  7. #22
    I have the same problem, XBOX One S won't connect to Netflix. Plus another problem: I can't access Dish Anywhere remotely. I talked to Dish Network Support this evening and I was told they were opening a case file on this because there have been other people who own this modem having the same problem. I too tried the "guest network" workaround to no avail, not to mention that this fix would also slow down the entire WIFI network if it did work. It's too late for me to try to return the modem so I am probably going to have to buy another new cable modem. If that's the case I will leave a scathing review on Amazon. Please TP Link, a firmware update should have been issued months ago.


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts

Copyright 1996-2017 TP-LINK Technologies Co., Ltd. All rights reserved.