Welcome to TP-LINK Tech Support Forum
+ Reply to Thread
Results 1 to 4 of 4
  1. #1

    Lightbulb TL-ER604W - L2TP/IPsec connection fails with iOS 10+ and Android 6.0.1

    Model : TL-ER604W
    Hardware Version : v1.0
    Firmware Version : 1.1.0 Build 20141031 Rel.32628s
    ISP : Bredbånd Nord (Broadband North) (local danish fiber provider)


    I can no longer establish a L2TP/IPsec connection (via WiFi hotspot or 4G/LTE/3G...) to my TL-ER604W router using iOS 10 and Android 6.0.1 devices.

    I have no problems connecting with an old Android 4.4.2 phone (WiFi or 4G/LTE/3G...) or Windows 7/10 computers.

    There may be an issue with Android 6.0.1 - But that doesn't explain why I cant connect with my iPhone using WiFi or 4G/LTE/etc.
    I'll have to try my iPhone on another WiFi network or another service provider (4G/LTE), though!! Maybe that will help.

    Maybe this firmware can help - Haven't tried it though - Don't know if I should.
    At the above location there's a .zip archive named "TL-ER604Wv1_141126.zip" - The archive contains a .bin-file called "TL-ER604W(UN)v1_en_1.1.0_[20141126-rel39500]_up.bin". It looks like a newer firmware version than the one I'm currently using. But since TP-Link hasn't linked to it at the official "download new firmware" site, I'm not sure I should install it.


    Kind regards
    Last edited by MuHcOw; 10-13-2016 at 20:37.

  2. #2
    The support team gave me a link to the following firmware:
    TL-ER604W(UN)v1_en_1.1.1_20160622-rel37338_up.zip

    Beta firmware - don't know how stable.

    [EDIT]
    The above firmware apparently solved my VPN-issues - iOS 10+ and Android 6.0.1 devices now connects just fine.
    I have asked TP-Link support if they could provide me with a detailed change log - I haven't heard from them yet.

    I hope it's stable.. Don't like installing updates without reading a change log first.

    Router now on: 1.1.1 Build 20160622 Rel.37338s

    Kind regards
    Last edited by MuHcOw; 10-13-2016 at 20:41.

  3. #3
    Members ChimB is on a distinguished road
    Join Date
    Nov 2015
    Posts
    111
    hmmm...as far as I know, they just changed the VPn part to let it work with the IOS10 weill

  4. #4

    iOS 11+?

    Quote Originally Posted by MuHcOw View Post
    The support team gave me a link to the following firmware:
    TL-ER604W(UN)v1_en_1.1.1_20160622-rel37338_up.zip

    Beta firmware - don't know how stable.

    [EDIT]
    The above firmware apparently solved my VPN-issues - iOS 10+ and Android 6.0.1 devices now connects just fine.
    I have asked TP-Link support if they could provide me with a detailed change log - I haven't heard from them yet.

    I hope it's stable.. Don't like installing updates without reading a change log first.

    Router now on: 1.1.1 Build 20160622 Rel.37338s

    Kind regards

    Can you advise if your iOS devices, if now running iOS 11+, still work with the ER604? If so, might you be willing to share all of your ER604 settings?

    Thanks so much!


 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts

Copyright © 1996-2018 TP-LINK Technologies Co., Ltd. All rights reserved.