Model :

Hardware Version :

Firmware Version :



My old CPL adapter burnt last week and and I am trying to replace it by a TP-link PA4015P.
I can't get internet connexion by plugging the brand new TL-PA4015P.
For several days now I try to understand what happen with no success.

My system is made of DELL Optiplex 755 equipped with windows 7 (32 bits version).
when I plug PA4015P all 3 LEDs are lighting properly (with green color) but windows the network icone shows no internet connection . Windows network diagnostic ends with error 651.
I tried a hotfix from Microsoft . But it did nor worked because not adapetd to my system.

Fortunately I have another computer upstair from which I got an old CPL made by OLITEC. As soon as I plug it to the DELL Optiplex 755 internet connection iworked immediately.( beside this why I can post this thread).

The question now is why the TL-PA4015P adapter is not working? Isn't it plug and play?
By the way. I bought a box with 2 adapters and I have alternatively plugged them both with no result.

Thanks for your help