Welcome to TP-LINK Tech Support Forum
+ Reply to Thread
Results 1 to 6 of 6
  1. #1

    Exclamation TD-W9970 Canada Firmware Download?

    Model :

    Hardware Version : Not Clear

    Firmware Version :

    ISP : [/COLOR]

    I upgraded the firmware from version:
    0.9.1 2.5 v0025.0 Build 150917 Rel.56865n_CA
    to
    0.9.1 2.8 v0025.0 Build 160705 Rel.41766n, and then I cannot set DSL up.


    I am afraid I made a mistake, because the new firmware is for TD-W9970(EU)_V1 but the original firmware "Rel.56865n_CA" maybe means for Canada.

    I cannot find the original firmware on the web. How can I get it or the latest one for Canada? Thanks.
    B.T.W. I cannot find the firmware download page in Canada's TP-link website: http://www.tplink.ca/en/products/det..._TD-W9970.html
    Yuefeng

  2. #2
    you probably gave up or found it already, but yes, you can find it on the canadian version of their site:

    http://www.tp-link.com/ca/download/T....html#Firmware

    http://static.tp-link.com/TD-W9970_C...211780089w.rar

  3. #3
    Thank you atomatom,
    I gave up not because it is not updated, but the only update cannot solve the problem of mine.
    Each time XBox One (and my LG smart TV) turned on, the ethernet connection is lost and can only be reconnected by hot-plugging out and in. I kept contacting the supporting team for a couple of months and gave up without any concrete solutions.

    There are far less version updates of Canada model than Europe or US, seems it is the forgotten market for TP-Link.

  4. #4
    strange, my one has no such issue, but I don't use IP TV. I would like some other things to work, like parental control.I wonder if you can use the us firmware. as far as I can tell, it is just the presets for ISPs and maybe allowed wifi radio channels

  5. #5
    i upgraded my canadian w9970 to TD-W9970(EU)_V1_161111 from http://www.tp-link.com.au/download/T....html#Firmware

    it seems fine. if there are any problems, i'll put it back to the canadian one.

    but it did not fix the broken parental control feature. (even if it worked, it is still pretty useless, because it does not work with https)

  6. #6
    Quote Originally Posted by atomatom View Post
    i upgraded my canadian w9970 to TD-W9970(EU)_V1_161111 from http://www.tp-link.com.au/download/T....html#Firmware
    it seems fine. if there are any problems, i'll put it back to the canadian one.
    but it did not fix the broken parental control feature. (even if it worked, it is still pretty useless, because it does not work with https)
    I have not tried non-Canadian version f/w to my router. Is AU version the latest updated version? Canadian and US are not updated frequently. Since the V2 hardware is there, I am afraid V1 will soon be forgotten.


 

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts

Copyright 1996-2017 TP-LINK Technologies Co., Ltd. All rights reserved.