Welcome to TP-LINK Tech Support Forum
+ Reply to Thread
Results 1 to 5 of 5
  1. #1

    TC-7610 Modem - Can't Change Admin Password

    Model :

    Hardware Version :

    Firmware Version :

    ISP : [/COLOR]

    Hello all,

    I log in with the defaults (admin and admin). I navigate to the password change screen. I change the password. It accepts the change. I logout and try to login again with the new password. It tells me the new password is invalid but the old password (now) doesn't work either. So, I reset the modem and try again to no avail. BTW, my ISP is Comcast. Could they possibly be prohibiting the password change? And finally, do I really need to be concerned about security here? The admin GUI only displays read-only information. I cannot change anything.

    In summary, I would really like to just stop trying to change the password if it does not pose any security threat.

    Thanks,

    gus

  2. #2
    are u using only numbers and alphabets? because you cant use anything else.

  3. #3
    Quote Originally Posted by Fmhotkeys View Post
    are u using only numbers and alphabets? because you cant use anything else.
    I opened a ticket on this issue when no one responded and support stated there is an unpublished limit on the number of alpha-numeric characters that can be used and that limit is very small. I was using 8 characters and that was over the limit so I just left it "as-is" because the unprotected login poses no real security threat as everything is read-only anyway.

  4. #4
    Junior Member HelenH is on a distinguished road
    Join Date
    Aug 2017
    Posts
    2

    Exclamation Default passwords are in use forever

    You are 1 of countless users having that same problem.
    It has been reported to TPLINK over and over again... by a huge number of users.
    TPLINK never fixes it.

    Anyone can fully access your device just by using "admin" and "admin".
    Forever.

    We had to send ALL of our TPLINK devices back to Amazon for a full refund.

  5. #5
    Quote Originally Posted by gustavio View Post
    I opened a ticket on this issue when no one responded and support stated there is an unpublished limit on the number of alpha-numeric characters that can be used and that limit is very small. I was using 8 characters and that was over the limit so I just left it "as-is" because the unprotected login poses no real security threat as everything is read-only anyway.
    You were able to change the admin password, right? Has any one encounter the same issue?


 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts

Copyright 1996-2017 TP-LINK Technologies Co., Ltd. All rights reserved.