Welcome to TP-LINK Tech Support Forum
+ Reply to Thread
Results 1 to 9 of 9
  1. #1

    Cool Ho to use your EAP Controller as a Windows Service

    Model :

    Hardware Version : Not Clear

    Firmware Version :

    ISP : [/COLOR]


    I thougt I could just add a small HowTo

    1) You EAP Controller Software is setup and running
    2) Download NSSM - the Non-Sucking Service Manager (https://nssm.cc/download)
    3) Extract nssm.exe to a convinient location (I used 'C:\Program Files (x86)\TP-LINK\EAP Controller\bin' to keep things together)
    4) Open a administrative shell
    5) cd to the place you placed nssm.exe
    6) Create a new Service using nssm: nssm install "EAP Controller"
    7) Edit the Created Service: nssm edit "EAP Controller"
    8) Set the following: (Adapt to your installation)
    C:\Program Files (x86)\TP-LINK\EAP Controller\jre\bin\eap.exe
    Startup Directory:
    C:\Program Files (x86)\TP-LINK\EAP Controller\jre\bin\eap.exe
     -server -Xmx1024m -XX:+UseConcMarkSweepGC -XX:+CMSClassUnloadingEnabled -XX:+UseCMSCompactAtFullCollection -XX:+HeapDumpOnOutOfMemoryError -Deap.home="C:\Program Files (x86)\TP-LINK\EAP Controller" -cp "C:\Program Files (x86)\TP-LINK\EAP Controller/lib/com.tp-link.eap.start-0.0.1-SNAPSHOT.jar;C:\Program Files (x86)\TP-LINK\EAP Controller/lib/*;C:\Program Files (x86)\TP-LINK\EAP Controller/external-lib/*" com.tp_link.eap.start.EapMain
    Description: Add one if you want
    Startup type: Automatic or Automatic (delayed start)
    Log on:
    I'm using 'Local System account'
    Set 'Allow service to interact with desktop'
    I added none
    Keep the defaults
    Stick with the defaults
    Exit Actions:
    I used
    Throttling '1500'
    'Restart application'
    and delay '0'
    Output and Error are nice debugging helps - I set them to:
    C:\Program Files (x86)\TP-LINK\EAP Controller\logs\svcstdout.log
    C:\Program Files (x86)\TP-LINK\EAP Controller\logs\svcstdout.log
    File rotation:
    Use it to keep your disk clean if you are using I/O
    set scriptDir="C:\Program Files (x86)\TP-LINK\EAP Controller\bin"
    set eapHome="C:\Program Files (x86)\TP-LINK\EAP Controller"

    That's it. Working fine for 7 months now ....
    Just remeber to stop the service before updating.
    I needed to restart server with the last EAP Controller Update cause I forgot to stop the service ...


  2. #2
    A brilliant workaround for the current 2.X controller. Thanks @the_MiCrO

  3. #3

    EAP-Controller Version 2.4.4


    I've tried this howto for EAP-Controler 2.4.2. It worked great.

    But now I've upgraded my EAP-Controller to 2.4.4.
    And now this howto dosen't work any more, becaus TP-Link changed something on the software.
    Maybe you've got a description for 2.4.4.

    At the moment i've to run the Software with a logged in User. That is a security problem for me, becaus a user has always logged on on the server.

    I tried to install the new version as a service with the PowerShell command:
    New-Service -Name "TP-Link EAP-Controler" -BinaryPathName "C:\Program Files (x86)\TP-LINK\EAP Controller\bin\EAP Controller.exe"
    but this was not successfull, the Service didn't start.
    The error 1053 is shown.

    Maybe someone has got a working way to install it as a service.

    Also it is a litle bit unusual that this controller cannot run as windows service by it default installation...

  4. #4
    Hi dlausch,

    don't know what went wrong for you. It's still working with Version 2.4.4 here.

    Did you try to remove the service, reboot and re-add it?

    And not installing a Service by itself is really uncommon....

  5. #5

    I retried the procedure now...
    What ever, now it worked...

    Sometimes windows don't like me...

    Thank you....

  6. #6

    EAP-Controller and FireDaemon

    Hi there,
    first of all greetings to all forum members from Germany.
    This is my first post here since I just registered.

    A big thank you to "the_MiCrO" for the very good "How to...".

    I'm using the EAP Controller 2.4.4 together with several EAP330.
    I also wanted to use the controller as a windows service.
    I'm using "FireDaemon Pro" instead of NSSM, but I followed exactly the steps which the_MiCrO entered here.
    At the end it works fine for me.
    But every time when the srvice starts I get the following error-message:
    Name:  ErrorMessage_FFD_EAPController.jpg
Views: 0
Size:  67.1 KB
    Has someone an idea what the reason is for these errors?
    Hope to get an answer soon.
    Thank you!

  7. #7
    Works fine for me.
    Don't know what are the variables in place that generate these errors for everyone.
    Revetement agro

  8. #8
    Hi,I have checked the procedure, it worked fine with win10 and XP sp3 on VM. There is a little error in start-up directory code: it is Code:"C:\Program Files (x86)\TP-LINK\EAP Controller\jre\bin\" Without "eap.exe"After this little change all goes well.

  9. #9
    I had trouble getting this to work with 2.4.7, but found an alternate solution. While it's not running as a service per se (and thus may be more difficult to monitor and restart on failure), if you're running Windows Server or a Pro/Enterprise/Ultimate flavor of Windows, you can use the Group Policy Editor to set "EAP Controller.exe" as a system startup "script".

    1. Start > Run > "gpedit.msc" to open the Group Policy Editor
    2. Local Computer Policy > Computer Configuration > Windows Settings > Scripts (Startup/Shutdown)
    3. Double-click "Startup" to open the Startup Scripts properties dialog
    4. Click "Add..." then click "Browse..."
    5. Navigate to the controller install path (e.g. "C:\Program Files (x86)\TP-LINK\EAP Controller\bin\" -- not the "jre\bin" one)
    6. Double-click "EAP Controller.exe" to select it then click OK to close out all the dialogs

    Now the controller will start next time your system reboots! The only downside is there's no "interactive" option, so the UI will be unavailable, and if you want to stop it you'll have to kill the eap.exe and javaw.exe processes via task manager (or powershell script or your other favorite means of killing processes).


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts

Copyright 1996-2017 TP-LINK Technologies Co., Ltd. All rights reserved.