Welcome to TP-LINK Tech Support Forum
+ Reply to Thread
Results 1 to 8 of 8
  1. #1

    USB Modem do not connect automatically

    Model : TL-MR3420

    Hardware Version : V2

    Firmware Version : 3.15.9 Build 140912 Rel.35984n

    ISP : Vodafone IT[/COLOR]

    I have a TL-MR3420 that I use to connect to Vodafone 4G Network via a USB Modem K5150.
    I set the router to connect automatically to the network but it doesn't.
    Name:  Schermata 2015-12-05 alle 18.29.19.jpg
Views: 0
Size:  55.3 KB
    So I need to enter the modem via and start the connection manually
    I also set the modem itself to connect automatically but it doesn't work too.
    Name:  Schermata 2015-12-05 alle 18.38.38.jpg
Views: 0
Size:  71.6 KB

    The connection is quite stable but if the power goes down the connection will not restart automatically after the router reboot.
    Any help?

    Attached Images  
    Last edited by barcl; 12-06-2015 at 10:58.

  2. #2
    If you have done the settings,it should auto connect to the Internet.
    What's the firmware version of the router?
    If it's not the latest one,you can upgrade it first.

  3. #3
    Hi same issue here!

    Same hardware configuration but I click "Connect" button to real connect to internet.

    Firmware Version: 3.15.9 Build 140912 Rel.35984n
    Hardware Version: MR3420 v2 00000000

  4. #4

    Problem still persist

    I have updated the router firmare to the latest available
    Firmware Version: 3.16.9 Build 150319 Rel.60489n
    Hardware Version: MR3420 v2 00000000
    I have also updated the USB modem firmare to the latest available

    Product name K5150
    Software Version 7.2
    Web UI Version 2.019.6384
    Hardware Version CH1K5150M

    but the problem still persist....
    The router status page shows that the USB modem is identified successfully and connected but the USB status page shows it is not connected.
    So I need to start the connection manually every time the routers is powered off or restarted.

    Is there any way to solve this problem?
    Is there a log I can provide to help in diagnose the problem?

    The K5150 is on the compatibility list for the MR3420 Router so I hope it would be made to work.


  5. #5
    have you solved this issue now?
    I also have the same problem, please help me..

  6. #6
    Quote Originally Posted by ariagussuwanto View Post
    have you solved this issue now?
    I also have the same problem, please help me..
    I decided to change the usb modem.
    I bought an Huawei E3372 and it works perfectly

  7. #7
    Junior Member bagishared is on a distinguished road
    Join Date
    Apr 2018


    Thank you my problem solved!


    download bokep

  8. #8
    This is great , glad im here to read this article

    live draw sydney hari ini


Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts

Copyright 1996-2018 TP-LINK Technologies Co., Ltd. All rights reserved.