Welcome to TP-LINK Tech Support Forum
+ Reply to Thread
Page 2 of 2 FirstFirst 1 2
Results 16 to 30 of 30
  1. #16

    Lightbulb Personal experience from a user

    For anyone who stumbles upon this thread, here is the current situation with this device:

    * The v6.30.223.228 driver distributed by TP-Link is for Windows 8.

    The "V1_151026" driver is referenced as a Windows 10 driver but this is not the case. The device is recognised as a 802.11n adapter, although it does reach 1.3Gbps as it's supposed to. I haven't noticed any major instability using this driver on Windows 10 though, it seems reasonably safe to use it.

    Download links: EU, USA

    * The v7.35 driver series is the correct one for Windows 10.

    Probably the better choice. With this driver the device is recognised as a 801.11ac adapter as it should be. I've had success with v7.35.333.0 and v7.35.338.0 found on station-drivers.com (thanks @somedude!), but not with v7.35.344.0 which seems to be for a different set of devices.
    If you prefer to download drivers from trusted sources, you can use the driver for the ASUS PCE-AC68 adapter, which uses the same BCM4360 chip as in the TP-Link Archer T9E/T8E.

    Download link (includes both EU and US)
    Last edited by antoineco; 03-10-2017 at 08:04.

  2. #17

    Newly installed T9E

    Just installed my T9E and ran a Speedtest from my Googe Fiber 100 connection.

    Speedtest.net (Ookla)
    Download 92.73
    Upload 97.25

    Driver details: TP-LINK 802.11ac Network Adapter
    Driver date 2/5/2014
    Driver version (Is this the latest?)
    Provider Broadcom Corporation

    Link speed (Receive/Transmit): 1300/877 (Mbps)

    Ran supplied CD provided with product and connected to my network without difficulty, but could not find Configurartion Utility that was supposed to have installed on my Windows 10 PC. When I attempted to run the setup file for it, the message popped up "Cannot run this program on this Operating System." Since TPLink eliminated the Configuration Utility from its Windows 10 installation this information had to be gathered from several sources. Downloaded latest driver from TP Support site, but no way to point it to driver installation unless I use the Device Manager from within Windows. This is apparently the only way. Support should notate that for customers. See http://www.tp-link.com/en/faq-920.html

    When you go to the TPLink Support site for downloads, you will note that the T9E driver for Windows 10 is labeled "Archer T9E_V1_151026". I don't know the source the previous post came from, but it works for me.

    In Windows 10, hold down the Logo/Start key + X- select Device Manager. Under Network Adapter(s) select the T9E and choose Update Driver. Point it to the above Archer T9E_V1_151026 and run it and it will report back that you already have the latest driver (if you installed the version)
    Last edited by Agent88; 03-10-2017 at 02:06. Reason: updated info

  3. #18
    Hi Everyone - New to the site and am glad I found this thread. Having trouble with my T9E. Windows 10 and have an ASROCK Z97 Pro 4 motherboard. The T9E was working fine when my PC was Windows 7 professional and using the drivers that came on the CD with the T9E. Then I decided to upgraded my graphics card from a Nvidia GeoForce GTX 970 to a GTX 1070 and do a windows upgrade to 10 at the same time. Windows 10 does not even recognize that my T9E is even in the system. I downloaded the TP-Link windows 10 zip file - Archer T9E_Vi_151026 and there is only 1 file in the zip file - a setup file. When I try to run that setup, the installation freezes windows 10 and the only choice is to do a hard boot. Then when windows comes back up, it is corrupted and I have to a completely new Windows install! Very frustrating! So I don't want to run that setup again and take a chance it will corrupt my windows 10 again. How can I install these Broadcom drivers that are mentioned by @somedude? Can I even install them if Windows 10 is not even seeing the T9E under device manager? What would you guys do?



  4. #19
    So I went ahead and installed the Broadcom driver that somedude recommended and IT WORKS! My T9E was immediately recognized in Device Manager as a Broadcom wireless adapter and I connected to my 5g wireless router at full speed. Thanks SomeDude!!!

  5. #20

    Change the channel on the router and in the T9E Settings

    Quote Originally Posted by macmuchmore View Post
    I installed a T9E in Windows 10 and it is working, but not at AC speeds. Do I need to do anything to enable this (yes I have an AC router)?
    I had the same problem, solved it changing the channel of the 5ghz network into the router and into the drivers settings of T9E.Try the channel 36 in both... AC net does not work in all of them for some reason in windows 10.

  6. #21
    Quote Originally Posted by somedude View Post
    Various driver problems have been widespread among many wireless AC cards, especially when trying to use them on Windows 10 x64 systems. For whatever reason, the Broadcom based wireless LAN cards have been a real trainwreck following the release of Windows 10. I for one am buying an Intel based card next time I need one. Until then, the Broadcom reference driver works a lot better than the manufacturers for several makes of wireless card, including Asus and Tplink. The Archer T9E is a BCM-4360 based card.

    Broadcomm BCM-43XX Wireless LAN driver 7.35.333.0 WHQL -- http://station-drivers.com/index.php?option=com_remository&Itemid=352&func=fi leinfo&id=1955&lang=en

    This driver works perfectly for me, got rid of numerous issues with the manufacturers driver. If it isn't quite right for you, you can also try searching for the older Broadcom wlan driver, which also worked perfectly for me.

    Doing a google search for either of these will lead you to discussions of the relative merits of the various Broadcom reference driver versions available.
    Thanks very much for this driver, it fixed another problem i was having with T9E. Since I bought it, in july last year, i was having problem while gaming, I found out that everytime I run a graphic-bound application (game or benchmark) my connection becames terrible. While I was just on everyday use of office and browsing the web the connection was excellent. First I assumed it was because the heat generated by the gpu (a gtx 770), but then I discover that before the gpu became barely hot my connection was already down. Then I suspect it maybe was a bottleneck on my motherboard. But then found out that althought the T9E is an pci-express card, it runs on a differente lane from the pci-e 16x of my gpu on my motherboard. I was about to ask for support when I saw your post and tried this driver. Got excellent pings on onlines games. Thanks man!!

  7. #22
    this is going crazy on Windows 10 Pro x64.
    ordered two devices (TP-Link Archer T9E, Chipset BCM4360) and (ASUS PCE-AC56, Chipset BCM4352). first i tried the drivers from Support-Website of TP-Link and Asus.
    next i tried all the Broadcom-drivers for Windows 10 (http://www.station-drivers.com/index...page=2&lang=en).
    ping and signal-strength are good so far, but the issues are likely the same with the different versions of wlan-driver. i made a lot of speedtests with the 20mbit internet-line.
    some of the tests are okay (about 25%) with stable dl-speed between 19-20mbit/s. most of the tests are not okay (about 75%) with unstable dl-speed between 5-15mbit/s.
    it can be that two testst are okay and the third pushes the speed up and down during the test. if you want to play an online-game like that, you have lags most of the time.
    how are your experiences over the last weeks? is it even possible to run a stable driver for Broadcom-Chipset or will it be better on ASUS PCE-AC55BT with Intel-chipset?

  8. #23
    You could also try the ASUS PCE-AC68 driver (see my post at the top of page 2) however the v7.35.338.0 driver from station-drivers has been stable all the way for me (steady download speed), although I haven't played only games.When you perform such test make sure you can't reproduce over a wired connection before taking conclusions, sometimes internet connections themselves have ups and downs. I have a 200Mb connection that occasionally goes as low as 80Mb/s during the bad days.

  9. #24
    Quote Originally Posted by antoineco View Post
    ... try the ASUS PCE-AC68 driver ...
    Seconded. It works perfectly and you can download / update from ASUS here: https://www.asus.com/us/Networking/P...Desk_Download/

    I recently chatted with a TP-Link support guy, just to check if this product had an working win10/64 driver offsite. It doesn't, and never will. These were the last TP-link product I or my company will ever purchase. If you can get a refund, do so.

  10. #25
    as i tested the driver from ASUS PCE-AC68 (Version i was also not happy with the output of it.
    i will choose the way to return the wlan-cards with broadcom-chipset (TP-Link Archer T9E and ASUS PCE-AC56).
    the third wlan-card i tested is a newer product (ASUS PCE-AC55BT) with intel-chipset and seems the best choise.
    as i installed the wlan-card it got plug-and-play-driver from 2015 and updated it with one of 2017 via device-manager.
    every speed-test is now between 19-20mbit/s as it was on my old card and as it should be on a new card as well

  11. #26
    I've tried all of the drivers mentioned in this thread and cannot get my Archer T9E to connect at full 1300Mbps to my network. The highest I get is 144.0Mbps. Currently, I'm using the ASUS driver and am trying to connect to a Cisco Meraki MR33 access point. Any ideas?

  12. #27
    2.4Ghz link speed is only 144Mpbs? try the higher channel width on the access points.

  13. #28
    Tried that, no change. I ended up cracking and getting an ASUS PCE-AC88 instead. Much better, though I also put in an RMA request for the Archer T9E, since the 5 GHz signal was extremely weak, even when the access point was less than 10 ft. away. I'll see if that fixes anything, and if so, then I'll put the card in a different PC.

  14. #29
    Junior Member Lucasizq is on a distinguished road
    Join Date
    Aug 2017

    It Worked!

    Quote Originally Posted by ferret View Post
    Ok found them on Softpedia and installed now. Driver is detecting as much newer than the latest TP Link one which is good and it now detects connection speed up to 1.3 gbps which it should be. On the previous driver it was only detecting speed at 877.5 mbps so bit happier that it is theoretically recognising the correct speed. Signal strength on 5ghz band is still only 3/5 bars so no improvement there so it may not be driver related although it isn't too far from modem

    Actual download speed is not much different, but I suspect that is a case of my internet not being particularly fast anyway

    Thanks a lot for that somedude, where would be the best place to watch for new drivers being released by Broadcom seeing as their website only seems to show Linux drivers
    So, i did what this guy did and went from getting around 70mbps to 250 although i am paying for 1gb, it is a huge jump!!

  15. #30
    Quote Originally Posted by somedude View Post
    Seconded. It works perfectly and you can download / update from ASUS here: https://www.asus.com/us/Networking/P...Desk_Download/

    I recently chatted with a TP-Link support guy, just to check if this product had an working win10/64 driver offsite. It doesn't, and never will. These were the last TP-link product I or my company will ever purchase. If you can get a refund, do so.
    yes, my archer t9e will also be my last tp-link product, i was gonna buy the archer c9 after t9e, but after sales services is just too bad, and wifi signal is not much better than my 10 year old d-link usb dongle, it's just bad.


Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts

Copyright 1996-2018 TP-LINK Technologies Co., Ltd. All rights reserved.